summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/bleach-3.1.4-r1.ebuild (renamed from dev-python/bleach/bleach-3.1.4.ebuild)10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/bleach/bleach-3.1.4.ebuild b/dev-python/bleach/bleach-3.1.4-r1.ebuild
index 5a78157e2d61..d80fe336be4a 100644
--- a/dev-python/bleach/bleach-3.1.4.ebuild
+++ b/dev-python/bleach/bleach-3.1.4-r1.ebuild
@@ -16,8 +16,18 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
IUSE="test"
RDEPEND="
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/webencodings[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py tests/test_clean.py || die
+
+ distutils-r1_src_prepare
+}