summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild')
-rw-r--r--dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild b/dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild
new file mode 100644
index 000000000000..35fbb53db361
--- /dev/null
+++ b/dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=FREW
+DIST_VERSION=0.080001
+inherit perl-module
+
+DESCRIPTION="Cryptographically-secure, cross-platform replacement for rand()"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Moo-2.0.0
+ >=dev-perl/Crypt-Random-Source-0.70
+ >=dev-perl/Math-Random-ISAAC-1.1.0
+ dev-perl/Math-Random-ISAAC-XS"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/List-MoreUtils
+ virtual/perl-Test-Simple
+ dev-perl/Test-SharedFork
+ dev-perl/Test-Warn
+ )
+"
+src_test() {
+ perl_rm_files t/author-*.t t/release-*.t
+ perl-module_src_test
+}