summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlbuild')
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild
index 524c937beda6..dfaf2d16bd32 100644
--- a/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild
@@ -21,6 +21,14 @@ RDEPEND="${DEPEND}
DEPEND="${DEPEND}
test? ( dev-ml/findlib )"
+src_prepare() {
+ sed -i \
+ -e "/package_exists/s:camlp4.macro:xxxxxx:" \
+ -e "/package_exists/s:menhirLib.macro:xxxxxx:" \
+ testsuite/external.ml || die
+ default
+}
+
src_configure() {
emake -f configure.make Makefile.config \
PREFIX="${EPREFIX}/usr" \
@@ -31,6 +39,11 @@ src_configure() {
NATDYNLINK=$(usex ocamlopt true false)
}
+src_compile() {
+ emake src/ocamlbuild_config.cmo
+ default
+}
+
src_install() {
emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
dodoc Changes