summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-containers/ocaml-containers-0.19.ebuild')
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-0.19.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/ocaml-containers-0.19.ebuild b/dev-ml/ocaml-containers/ocaml-containers-0.19.ebuild
new file mode 100644
index 000000000000..9b88e573f8e9
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-0.19.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/result:=
+ dev-ml/sequence:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo"
+PATCHES=( "${FILESDIR}/notests.patch" )
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}