summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/biniou/biniou-1.1.0.ebuild')
-rw-r--r--dev-ml/biniou/biniou-1.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/biniou/biniou-1.1.0.ebuild b/dev-ml/biniou/biniou-1.1.0.ebuild
new file mode 100644
index 000000000000..6a9705355a2a
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="https://github.com/mjambon/biniou"
+SRC_URI="https://github.com/mjambon/biniou/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}