summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/astring/astring-0.8.5.ebuild')
-rw-r--r--dev-ml/astring/astring-0.8.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/astring/astring-0.8.5.ebuild b/dev-ml/astring/astring-0.8.5.ebuild
new file mode 100644
index 000000000000..a922e9b805db
--- /dev/null
+++ b/dev-ml/astring/astring-0.8.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Alternative String module for OCaml"
+HOMEPAGE="https://erratique.ch/software/astring https://github.com/dbuenzli/astring"
+SRC_URI="https://erratique.ch/software/astring/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+
+OCAML_DEP=">=dev-lang/ocaml-4.05.0:="
+BDEPEND="
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+ dev-ml/topkg
+ ${OCAML_DEP}
+"
+RDEPEND="${OCAML_DEP}"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}