summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libvformat')
-rw-r--r--dev-libs/libvformat/Manifest3
-rw-r--r--dev-libs/libvformat/files/libvformat-1.13-has_unistd.patch13
-rw-r--r--dev-libs/libvformat/files/libvformat-1.13-str.patch22
-rw-r--r--dev-libs/libvformat/files/libvformat-nodoc.patch8
-rw-r--r--dev-libs/libvformat/libvformat-1.13-r1.ebuild35
-rw-r--r--dev-libs/libvformat/libvformat-1.13-r2.ebuild39
-rw-r--r--dev-libs/libvformat/metadata.xml5
7 files changed, 125 insertions, 0 deletions
diff --git a/dev-libs/libvformat/Manifest b/dev-libs/libvformat/Manifest
new file mode 100644
index 000000000000..459b39fae0cb
--- /dev/null
+++ b/dev-libs/libvformat/Manifest
@@ -0,0 +1,3 @@
+DIST libvformat_1.13-10.debian.tar.gz 25884 SHA256 b6bce7be6ff945b99f98061542908a10d1b5fc8c83d1b8a584bb5163da4b9058 SHA512 fd3635a697cf52215a024118dd5e7776829ec2e537a6795121361046588be23f00225fafc50e14e25e94e94659bb16d7830193b159925c63ff2e0644394b3626 WHIRLPOOL a3c77e6970a48e0f190ae05dc85da1038708ae291a5fd236f91878ff6e4bde607809efbb333ff0bd0905badaf2f2f36b547665e29ded123e93ee849d34196c43
+DIST libvformat_1.13-4.diff.gz 361732 SHA256 1593343cfc3f1ab746a1a245caf1562dfceac77c92c9cdbb107ee1eced4c0552 SHA512 96110754385d3b07e196c1f225c7bdfd1487390a5f462457a4835c27306db680b44c964db7d780a8e394e3b3e144727f8485812ba74b69afabfa0f40ed736ded WHIRLPOOL 3ad0d183f89a4c2b33f90007cdd0612d9937373d4614f6d035bf25aa7abc38cfe089948d8db3098b614020a825ab23748005112260b06f0e3af4c612cc0abb7f
+DIST libvformat_1.13.orig.tar.gz 254463 SHA256 7251fda5f90e56ea5d132399010c0b40e7dc55085efaf17ba724037e71f7d966 SHA512 80b47897dd4f5dfa05e78a40de821406a007e330fc82584a0d26e2d1580a5ce52b6af90ecd4c0f7f36eaf00d6a78d9ba3b84ec2b7c7d814ba890a629d7a2c7ba WHIRLPOOL 321da3e974b6ef5dad621531e5674d783b7c84a8e143bc3565fa5157105854e41cb2d3091e080834f793a690c126b26e76e3f5a7255b9602b1d9d8217ca514fb
diff --git a/dev-libs/libvformat/files/libvformat-1.13-has_unistd.patch b/dev-libs/libvformat/files/libvformat-1.13-has_unistd.patch
new file mode 100644
index 000000000000..8788c966ffd0
--- /dev/null
+++ b/dev-libs/libvformat/files/libvformat-1.13-has_unistd.patch
@@ -0,0 +1,13 @@
+--- a/src/vf_reader.c
++++ b/src/vf_reader.c
+@@ -87,8 +87,9 @@
+
+ #include <stdio.h>
+ #include <sys/stat.h>
++#include "config.h"
+
+-#if defined(HAS_UNISTD_H)
++#if defined(HAVE_UNISTD_H)
+ #include <unistd.h>
+ #endif
+
diff --git a/dev-libs/libvformat/files/libvformat-1.13-str.patch b/dev-libs/libvformat/files/libvformat-1.13-str.patch
new file mode 100644
index 000000000000..8c47489842d8
--- /dev/null
+++ b/dev-libs/libvformat/files/libvformat-1.13-str.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,7 +21,7 @@
+ # Checks for library functions.
+ AC_FUNC_MKTIME
+ AC_FUNC_STAT
+-AC_CHECK_FUNCS([atexit memset strstr])
++AC_CHECK_FUNCS([atexit memset strstr strlen strcpy strcmp strcat memcpy])
+
+ AC_OUTPUT([Makefile src/Makefile vformat/Makefile test/Makefile doc/Makefile])
+ #AC_CONFIG_FILES([])
+--- a/src/vf_config.h
++++ b/src/vf_config.h
+@@ -31,6 +31,8 @@
+ *
+ *******************************************************************************/
+
++#include <config.h>
++
+ #ifndef _VF_CONFIG_H_
+ #define _VF_CONFIG_H_
+
diff --git a/dev-libs/libvformat/files/libvformat-nodoc.patch b/dev-libs/libvformat/files/libvformat-nodoc.patch
new file mode 100644
index 000000000000..e9dd55ce25ef
--- /dev/null
+++ b/dev-libs/libvformat/files/libvformat-nodoc.patch
@@ -0,0 +1,8 @@
+--- Makefile.am.orig 2005-08-12 13:36:39.000000000 +0200
++++ Makefile.am 2005-08-12 13:36:57.000000000 +0200
+@@ -1,4 +1,4 @@
+-SUBDIRS = src vformat test doc
++SUBDIRS = src vformat
+
+ EXTRA_DIST = common/types.h vf_iface.h
+
diff --git a/dev-libs/libvformat/libvformat-1.13-r1.ebuild b/dev-libs/libvformat/libvformat-1.13-r1.ebuild
new file mode 100644
index 000000000000..0f10a8634168
--- /dev/null
+++ b/dev-libs/libvformat/libvformat-1.13-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="Library to read and write vcard files"
+HOMEPAGE="http://sourceforge.net/projects/vformat/"
+SRC_URI="mirror://debian/pool/main/libv/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/libv/${PN}/${PN}_${PV}-4.diff.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P}.orig"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${DISTDIR}/${PN}_${PV}-4.diff.gz" || die "epatch failed"
+
+ # Patch for not installing documentation, because that needs c2man
+ epatch "${FILESDIR}/${PN}-nodoc.patch" || die "epatch failed"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/dev-libs/libvformat/libvformat-1.13-r2.ebuild b/dev-libs/libvformat/libvformat-1.13-r2.ebuild
new file mode 100644
index 000000000000..e7d4b2de58f5
--- /dev/null
+++ b/dev-libs/libvformat/libvformat-1.13-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Library to read and write vcard files"
+HOMEPAGE="http://sourceforge.net/projects/vformat/"
+SRC_URI="
+ mirror://debian/pool/main/libv/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/libv/${PN}/${PN}_${PV}-10.debian.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+S="${WORKDIR}/${P}.orig"
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/debian/patches/*.patch \
+ "${FILESDIR}"/${PN}-nodoc.patch \
+ "${FILESDIR}"/${P}-has_unistd.patch \
+ "${FILESDIR}"/${P}-str.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}
diff --git a/dev-libs/libvformat/metadata.xml b/dev-libs/libvformat/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/dev-libs/libvformat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>