summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-21.37.20939.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 593cc737126f..d63cf57e0391 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,4 +1,3 @@
-DIST intel-compute-runtime-21.37.20939.tar.gz 4576917 BLAKE2B 42563ce897667025100b40f504fe4897222fd28f1b82ac22fb6cfaa6a273b8e9199d57743ab338ab52b32c9598bbf6856530688ca9cbff360db356dabed6d96b SHA512 ed213e2fd234300ac940ffa503a34ae54698e2d359927b3bdcb59bf7ea9d6b950073e9e2e750ec5b8e3e387f0c8d74b4852627c283964fd6a9742dcdc32f518f
DIST intel-compute-runtime-21.38.21026.tar.gz 4655853 BLAKE2B 28ebfb1cbce30fdefb7104a2b6840ea95d62645ae51a97a0b970aa4344fca7e64eb8f289895c30cf9fe4a0d9e5294490810236c0e565e78383ad7096429e2155 SHA512 08ffaaed80ef5776e6ecff15467170ca143887cda7905a49f7b2d12862ff17e75e7ff89ff2bb76ce25eec4ef32dfc882ac3cddf5a3e71d24adb21cc8c806cf5b
DIST intel-compute-runtime-21.39.21127.tar.gz 4666632 BLAKE2B 0e63e1bdf152e9995d48bc514ad86ce107ab7a62946b349f88fee3dfea89c93d3c2c7ce0ff3fd670d9944fa563cb409a04ae65820f3bb591f56638a7be54ec16 SHA512 7f526ec6f3c38586f75bcb0acdc312fc954655f2a92f78e820be722c27cac60b961b73897a1bd4ceeb397abdf3565be5e9c0859a0906723cb79e2947df2d2136
DIST intel-compute-runtime-21.40.21182.tar.gz 4678271 BLAKE2B c8f5c324af0e8ef787b287ee1e3fcacc217c3d935ce859123a217c088323f97a80293749689959be22502e7f569ad0fb917868c526dcea7905e80585e7376f53 SHA512 fdf74ae700a444ba9732938d9cdda3ba6f6baac209ca1611488b405a4ecced7cdd434a9e349af8a095b5adcd583b84294cb831ddc785520cd697a7af1ffa0437
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-21.37.20939.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.37.20939.ebuild
deleted file mode 100644
index 5633f12637ba..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-21.37.20939.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND="
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-compiler-1.0.8517-r1
- >=dev-util/intel-graphics-system-controller-0.2.3
- >=media-libs/gmmlib-21.2.1
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.4.1 )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- x11-libs/libva
- )
-"
-
-# for Khronos OpenGL headers
-DEPEND="
- ${RDEPEND}
- media-libs/mesa
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-PATCHES=( "${FILESDIR}/${PN}-21.31.20514-no_Werror.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="ON"
- )
-
- cmake_src_configure
-}