summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/c-blosc/files')
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch21
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.19.0-xgetbv.patch33
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch b/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
deleted file mode 100644
index d385d5263710..000000000000
--- a/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Make the build system respect CFLAGS
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -244,16 +244,6 @@
- endif()
-
- # flags
--# @TODO: set -Wall
--# @NOTE: -O3 is enabled in Release mode (CMAKE_BUILD_TYPE="Release")
--
--# Set the "-msse2" build flag only if the CMAKE_C_FLAGS is not already set.
--# Probably "-msse2" should be appended to CMAKE_C_FLAGS_RELEASE.
--if(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
-- if(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
-- set(CMAKE_C_FLAGS -msse2 CACHE STRING "C flags." FORCE)
-- endif(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
--endif(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
-
- if(MSVC)
- if(NOT CMAKE_C_FLAGS)
diff --git a/dev-libs/c-blosc/files/c-blosc-1.19.0-xgetbv.patch b/dev-libs/c-blosc/files/c-blosc-1.19.0-xgetbv.patch
deleted file mode 100644
index 045a234028be..000000000000
--- a/dev-libs/c-blosc/files/c-blosc-1.19.0-xgetbv.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 14d2d561795c276fc33c8cb54781dff76b398906 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 10 Jun 2020 12:13:39 +0200
-Subject: [PATCH] Redefine blosc_internal_xgetbv for platforms with immintrin.h
-
-Commit 2f2d876 renamed _xgetbv to blosc_internal_xgetbv. Commit 0b8608b
-made it conditional to immintrin.h not being included, apparently
-in order to prevent _xgetbv collision. However, since the block
-no longer defined _xgetbv but blosc_internal_xgetbv, it means that
-the latter is not defined if the condition is false. #define it to
-_xgetbv to fix missing symbol.
----
- blosc/shuffle.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/blosc/shuffle.c b/blosc/shuffle.c
-index fc2ca64..7a03bf1 100644
---- a/blosc/shuffle.c
-+++ b/blosc/shuffle.c
-@@ -195,6 +195,10 @@ blosc_internal_xgetbv(uint32_t xcr) {
- return ((uint64_t)edx << 32) | eax;
- }
-
-+#else
-+
-+#define blosc_internal_xgetbv _xgetbv
-+
- #endif // !(defined(_IMMINTRIN_H_INCLUDED) && (BLOSC_GCC_VERSION >= 900))
- #endif /* defined(_MSC_FULL_VER) */
-
---
-2.27.0
-