summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/vala/vala-0.20.1.ebuild')
-rw-r--r--dev-lang/vala/vala-0.20.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/vala/vala-0.20.1.ebuild b/dev-lang/vala/vala-0.20.1.ebuild
new file mode 100644
index 000000000000..7a78c841b2e8
--- /dev/null
+++ b/dev-lang/vala/vala-0.20.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Compiler for the GObject type system"
+HOMEPAGE="http://live.gnome.org/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0.20"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="test +vapigen"
+
+RDEPEND="
+ >=dev-libs/glib-2.18:2
+ >=dev-libs/vala-common-${PV}"
+DEPEND="${RDEPEND}
+ !${CATEGORY}/${PN}:0
+ dev-libs/libxslt
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2 )"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ --disable-unversioned \
+ $(use_enable vapigen)
+}