summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild')
-rw-r--r--dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild b/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
new file mode 100644
index 000000000000..a3fa62e101e4
--- /dev/null
+++ b/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Test Utililty Pack for HUnit and QuickCheck (unmaintained)"
+HOMEPAGE="https://github.com/jgoerzen/testpack"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/quickcheck-2.1.0.3:2=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-qc28.patch
+}