summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/options/options-1.2-r1.ebuild')
-rw-r--r--dev-haskell/options/options-1.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/options/options-1.2-r1.ebuild b/dev-haskell/options/options-1.2-r1.ebuild
new file mode 100644
index 000000000000..900e3b513290
--- /dev/null
+++ b/dev-haskell/options/options-1.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A powerful and easy-to-use command-line option parser"
+HOMEPAGE="https://john-millikin.com/software/haskell-options/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/monads-tf-0.1:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/chell-0.3.1 <dev-haskell/chell-0.5
+ >=dev-haskell/chell-quickcheck-0.2 <dev-haskell/chell-quickcheck-0.3
+ >=dev-haskell/monads-tf-0.1
+ >=dev-haskell/transformers-0.2 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'chell >= 0.3.1 && < 0.4' 'chell >= 0.3.1 && < 0.5'
+}