summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/mmorph')
-rw-r--r--dev-haskell/mmorph/Manifest4
-rw-r--r--dev-haskell/mmorph/metadata.xml9
-rw-r--r--dev-haskell/mmorph/mmorph-1.0.0.ebuild25
-rw-r--r--dev-haskell/mmorph/mmorph-1.0.2.ebuild26
-rw-r--r--dev-haskell/mmorph/mmorph-1.0.3.ebuild26
-rw-r--r--dev-haskell/mmorph/mmorph-1.0.4.ebuild26
6 files changed, 116 insertions, 0 deletions
diff --git a/dev-haskell/mmorph/Manifest b/dev-haskell/mmorph/Manifest
new file mode 100644
index 000000000000..b48faa786ef4
--- /dev/null
+++ b/dev-haskell/mmorph/Manifest
@@ -0,0 +1,4 @@
+DIST mmorph-1.0.0.tar.gz 4989 SHA256 13c369262821a86915ee18598567474e1489b49f19f9be8335252b6359762883 SHA512 789e50edb576c8443003926c697bf977e858d9814704ba6279cbe67c179331fbeb8599bd9284caa4b68808acfd8d8053a006442e29b9e56376b1abfe463e7ad4 WHIRLPOOL e2732bd6aa0796945f79f0d086c50d5e13ecf9498b4901a360859464260ef945be7b3372e8144f12229782e7a9aad3149ff960467e030c5029cfba0036a3e107
+DIST mmorph-1.0.2.tar.gz 6021 SHA256 904b16bf9c876e1bec4a2dbcd709c0504f18e3080adb0fc264de0f777ab11634 SHA512 8117eb606922e7901b1a27f0a6a1f4722ac8c4ed609e5f33a7b472677289960f9b91dd0e5b534e02d3331a9114d053bf5f2d45dd0bd33a0085e6849baea4ae64 WHIRLPOOL 3c8fc1ef8b1e421690bdf90d4f9afd437166be3854555a2214015d0c818256a39002838208d95e38508e91557394a65987da001988916b7d7b0b683992524222
+DIST mmorph-1.0.3.tar.gz 6023 SHA256 151bd6a93bcaabbc7ad0b106fe286129568837d7e3488fb86483f73fccfa172d SHA512 1ffd5e5226f5024552df2b9e6503579e9a7da499b4b384b1cf6b379257777e4573db62b0bef00b39add523c6fac34b401fabb4dd9ddf9e83ed5606bb15544080 WHIRLPOOL 4ed43197ba85a3b2c332cafc9705f9b413f2fbc7952b13ef9531d4899eca8f18599f6be545600f2197318f8296d5cd6dd0c5650a7b03aa589c55ea2fe86faaf3
+DIST mmorph-1.0.4.tar.gz 6100 SHA256 22e3665b4c86bf28cb4e836da91f586294d74d1cf1c18db364dcf568eba7bf4c SHA512 49f403a82e1d1f8db2e27b77d490fa4e574e0b18346756a803ba9e8d71cee4d8f9d66c228f5a4eb27680132b9e4e346cd1f80238ce1bfc553eee37d96d98c386 WHIRLPOOL ad438ee12b1d5eeb16863a4a4f622f69e6a2570590649f08f2d4f170c00879dd157f1ab6c52e6a06cd83f94a7312b3798d283686d4d8a6e29a3c6f5676dd4cec
diff --git a/dev-haskell/mmorph/metadata.xml b/dev-haskell/mmorph/metadata.xml
new file mode 100644
index 000000000000..2635091a8c93
--- /dev/null
+++ b/dev-haskell/mmorph/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library provides monad morphism utilities, most commonly used
+ for manipulating monad transformer stacks.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/mmorph/mmorph-1.0.0.ebuild b/dev-haskell/mmorph/mmorph-1.0.0.ebuild
new file mode 100644
index 000000000000..009ee9e404bd
--- /dev/null
+++ b/dev-haskell/mmorph/mmorph-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monad morphisms"
+HOMEPAGE="http://hackage.haskell.org/package/mmorph"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2.0.0:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2"
diff --git a/dev-haskell/mmorph/mmorph-1.0.2.ebuild b/dev-haskell/mmorph/mmorph-1.0.2.ebuild
new file mode 100644
index 000000000000..9463f8d56bd5
--- /dev/null
+++ b/dev-haskell/mmorph/mmorph-1.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monad morphisms"
+HOMEPAGE="http://hackage.haskell.org/package/mmorph"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2.0.0:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
diff --git a/dev-haskell/mmorph/mmorph-1.0.3.ebuild b/dev-haskell/mmorph/mmorph-1.0.3.ebuild
new file mode 100644
index 000000000000..624b18d8c95a
--- /dev/null
+++ b/dev-haskell/mmorph/mmorph-1.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monad morphisms"
+HOMEPAGE="http://hackage.haskell.org/package/mmorph"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2.0.0:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
diff --git a/dev-haskell/mmorph/mmorph-1.0.4.ebuild b/dev-haskell/mmorph/mmorph-1.0.4.ebuild
new file mode 100644
index 000000000000..0d7a7c003c8a
--- /dev/null
+++ b/dev-haskell/mmorph/mmorph-1.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monad morphisms"
+HOMEPAGE="http://hackage.haskell.org/package/mmorph"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2.0.0:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"