summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/language-c/language-c-0.4.2.ebuild')
-rw-r--r--dev-haskell/language-c/language-c-0.4.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/language-c/language-c-0.4.2.ebuild b/dev-haskell/language-c/language-c-0.4.2.ebuild
new file mode 100644
index 000000000000..bb31503089e4
--- /dev/null
+++ b/dev-haskell/language-c/language-c-0.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Analysis and generation of C code"
+HOMEPAGE="http://www.sivity.net/projects/language.c/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/syb[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.6
+ dev-haskell/happy"
+
+src_prepare() {
+ rm -vf "${S}"/dist/build/Language/C/Parser/{Lexer,Parser}.hs
+}