summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/http/http-4000.2.6.ebuild')
-rw-r--r--dev-haskell/http/http-4000.2.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/http/http-4000.2.6.ebuild b/dev-haskell/http/http-4000.2.6.ebuild
new file mode 100644
index 000000000000..803aaf3942ec
--- /dev/null
+++ b/dev-haskell/http/http-4000.2.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="https://github.com/haskell/HTTP"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+RESTRICT=test # needs depends missing in our overlay
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?]
+ <dev-haskell/mtl-2.2:=[profile?]
+ <dev-haskell/network-2.5:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"
+
+S="${WORKDIR}/${MY_P}"