summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hoauth2')
-rw-r--r--dev-haskell/hoauth2/Manifest3
-rw-r--r--dev-haskell/hoauth2/hoauth2-0.4.5.ebuild36
-rw-r--r--dev-haskell/hoauth2/hoauth2-0.4.6.ebuild41
-rw-r--r--dev-haskell/hoauth2/hoauth2-0.4.8.ebuild36
-rw-r--r--dev-haskell/hoauth2/metadata.xml19
5 files changed, 135 insertions, 0 deletions
diff --git a/dev-haskell/hoauth2/Manifest b/dev-haskell/hoauth2/Manifest
new file mode 100644
index 000000000000..ed860b4a33cf
--- /dev/null
+++ b/dev-haskell/hoauth2/Manifest
@@ -0,0 +1,3 @@
+DIST hoauth2-0.4.5.tar.gz 8467 SHA256 3adba22fbe36cf88eaa918d7e1b68380bf2e4af3bc9ae1939c401131a73fb6d3 SHA512 c00b6543af4d0da409d8919cc88fc75f80974ed1cee2ba8d262654b656239dde937a16eedce253a90b8d2e4efab2aa59fb2de84497f7740b6dae7d5823ca66d2 WHIRLPOOL d6057bfc34dc3f0ce3d7a044990a5d28a6b63abb84859f53ac5e66c5f10faa49874653bcc18ef55371306877585e6a3abcd90b681275d1176bd1004bd7b36be2
+DIST hoauth2-0.4.6.tar.gz 8615 SHA256 97234e47514c80252644edc4873140e64c16349bcf39e8e9d971cd7577a8c2ea SHA512 bb09d8a514ca4a5e2038e1b67ce3a23e53e3b5d87c7e1933276c5b9596f67fc10256705d4ab3b4bce74aba5cf70b404084baaca40103dda0ed4d529c2beb7368 WHIRLPOOL 4530f530c6927ae33c8ff7f8a0e3e8e80f5f3ae7d58fe368f94a9bc7c1b701e74cc2eaccfb71c9ef89ec8f8825f231fa43bb22b5c0a7ebebb177c35328467f99
+DIST hoauth2-0.4.8.tar.gz 8599 SHA256 6e489820dee16b926225e58555032e32d345b234b5a798db6e5a1d63d2843093 SHA512 b2abf00d0ae7d15911f4a1e17d90d6f0b3931800bc66d77545c566fc64de527cfc86121b57a4ff4187a4a0aa81aea2e150412bf928fdec8e506ab24f9e1bea29 WHIRLPOOL 0f4a9ea0bfeb3dbd5e123bd079a227202fa510f5ea3a149474257d78c8e3c051482884f32a391db33a9f786d965f0c831170b2570cc80e7ef25094ac924a25b1
diff --git a/dev-haskell/hoauth2/hoauth2-0.4.5.ebuild b/dev-haskell/hoauth2/hoauth2-0.4.5.ebuild
new file mode 100644
index 000000000000..4bdf1027d74b
--- /dev/null
+++ b/dev-haskell/hoauth2/hoauth2-0.4.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT=test # missing files
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-0.9:=[profile?]
+ >=dev-haskell/http-conduit-2.0:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test test)
+}
diff --git a/dev-haskell/hoauth2/hoauth2-0.4.6.ebuild b/dev-haskell/hoauth2/hoauth2-0.4.6.ebuild
new file mode 100644
index 000000000000..81339caefaa4
--- /dev/null
+++ b/dev-haskell/hoauth2/hoauth2-0.4.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT=test # missing files
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-0.9:=[profile?]
+ >=dev-haskell/http-conduit-2.0:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'bytestring >= 0.10.4 && < 0.10.5' 'bytestring >= 0.10.4'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test test)
+}
diff --git a/dev-haskell/hoauth2/hoauth2-0.4.8.ebuild b/dev-haskell/hoauth2/hoauth2-0.4.8.ebuild
new file mode 100644
index 000000000000..1679e75a002b
--- /dev/null
+++ b/dev-haskell/hoauth2/hoauth2-0.4.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT=test # missing files
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-0.10:=[profile?]
+ >=dev-haskell/http-conduit-2.0:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test test)
+}
diff --git a/dev-haskell/hoauth2/metadata.xml b/dev-haskell/hoauth2/metadata.xml
new file mode 100644
index 000000000000..b0d232fcbacc
--- /dev/null
+++ b/dev-haskell/hoauth2/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Haskell OAuth2 authentication.
+
+ Tested following services
+
+ * google web oauth: &lt;https://developers.google.com/accounts/docs/OAuth2WebServer&gt;
+
+ * weibo oauth2: &lt;http://open.weibo.com/wiki/Oauth2&gt;
+
+ * github oauth: &lt;http://developer.github.com/v3/oauth/&gt;
+ </longdescription>
+ <upstream>
+ <remote-id type="github">freizl/hoauth2</remote-id>
+ </upstream>
+</pkgmetadata>