summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/data-binary-ieee754/data-binary-ieee754-0.4.2.1.ebuild')
-rw-r--r--dev-haskell/data-binary-ieee754/data-binary-ieee754-0.4.2.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-haskell/data-binary-ieee754/data-binary-ieee754-0.4.2.1.ebuild b/dev-haskell/data-binary-ieee754/data-binary-ieee754-0.4.2.1.ebuild
new file mode 100644
index 000000000000..c16433ae3925
--- /dev/null
+++ b/dev-haskell/data-binary-ieee754/data-binary-ieee754-0.4.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="Parser/Serialiser for IEEE-754 floating-point values"
+HOMEPAGE="http://john-millikin.com/software/data-binary-ieee754/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="<dev-haskell/binary-0.6
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"