summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/crypto-random')
-rw-r--r--dev-haskell/crypto-random/Manifest3
-rw-r--r--dev-haskell/crypto-random/crypto-random-0.0.7.ebuild27
-rw-r--r--dev-haskell/crypto-random/crypto-random-0.0.8.ebuild27
-rw-r--r--dev-haskell/crypto-random/crypto-random-0.0.9.ebuild27
-rw-r--r--dev-haskell/crypto-random/metadata.xml11
5 files changed, 95 insertions, 0 deletions
diff --git a/dev-haskell/crypto-random/Manifest b/dev-haskell/crypto-random/Manifest
new file mode 100644
index 000000000000..862a549f8532
--- /dev/null
+++ b/dev-haskell/crypto-random/Manifest
@@ -0,0 +1,3 @@
+DIST crypto-random-0.0.7.tar.gz 8999 SHA256 bccb1fda2d29a3af9e476ed019231a4d2a53fef4f048c4dde9c10d5a901f46b6 SHA512 7e96f602c2cd194601f7feeb4589ab4606542c81bc27b566edb90030c010da3998b235cd2b229ca781ea147defe4677077897343b4ef561e0858ad71a4a7a409 WHIRLPOOL f42b697336477fc60b8b4c6f3e7db5bd520e63b3bf374d3953b6bb4f5159ad13953bb38f8d54fe489d401b44d283078a12d00305601778ad1565a4224a80b7cc
+DIST crypto-random-0.0.8.tar.gz 9061 SHA256 7b2e5e2e2a1863d346e3c3fdfef652e087ad6176ac88fede8ab9445b40a51115 SHA512 f6c1dddacdd7b51846ec8b762649281826f7757e5ef5fb556c9355eed559ff310f2b3dda9e4b4c39fd400d996db476f73c6b5fc14b63c361025c0ae780286e63 WHIRLPOOL 1c548334b6ed0b48f0ec19be48f40a017021cc96a7e1bc52429444a5bb2c032f7c44021292863cab42e16e16d2571006e72c2c868e833b3af220355a292d0cef
+DIST crypto-random-0.0.9.tar.gz 9256 SHA256 170a7a18441379c2d1c19b502ee5919026a19adc6e78641cd4fb40b1d69a6904 SHA512 07e298e2e3846b48330af92a46ab8550982ad74f6154c59a531762d9282f6712c1e867a48ed6cf4d967f463f52c1af4287a74552aeff0635480ea21cd54a7a24 WHIRLPOOL d54c875a18a7a1fc7d6e55ee1303b6e9715c9b894e1e4803acc1a724d8239c1795b4a34d0dec4007139590e804e65eced825fd0e7dfd023f09268695f039e5bd
diff --git a/dev-haskell/crypto-random/crypto-random-0.0.7.ebuild b/dev-haskell/crypto-random/crypto-random-0.0.7.ebuild
new file mode 100644
index 000000000000..320dfeef4507
--- /dev/null
+++ b/dev-haskell/crypto-random/crypto-random-0.0.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple cryptographic random related types"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-random"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/securemem:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
diff --git a/dev-haskell/crypto-random/crypto-random-0.0.8.ebuild b/dev-haskell/crypto-random/crypto-random-0.0.8.ebuild
new file mode 100644
index 000000000000..df8d52291fe1
--- /dev/null
+++ b/dev-haskell/crypto-random/crypto-random-0.0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple cryptographic random related types"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-random"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/securemem:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/crypto-random/crypto-random-0.0.9.ebuild b/dev-haskell/crypto-random/crypto-random-0.0.9.ebuild
new file mode 100644
index 000000000000..880a92f70ac3
--- /dev/null
+++ b/dev-haskell/crypto-random/crypto-random-0.0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple cryptographic random related types"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-random"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/securemem:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/crypto-random/metadata.xml b/dev-haskell/crypto-random/metadata.xml
new file mode 100644
index 000000000000..df9b27c0a494
--- /dev/null
+++ b/dev-haskell/crypto-random/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Simple cryptographic random related types
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-random</remote-id>
+ </upstream>
+</pkgmetadata>