summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/alex/alex-3.0.5.ebuild')
-rw-r--r--dev-haskell/alex/alex-3.0.5.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-haskell/alex/alex-3.0.5.ebuild b/dev-haskell/alex/alex-3.0.5.ebuild
new file mode 100644
index 000000000000..fd3a06a297b0
--- /dev/null
+++ b/dev-haskell/alex/alex-3.0.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin test-suite"
+inherit autotools eutils haskell-cabal
+
+DESCRIPTION="Alex is a tool for generating lexical analysers in Haskell"
+HOMEPAGE="http://www.haskell.org/alex/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ >=dev-haskell/quickcheck-2
+ >=dev-lang/ghc-6.10.4
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+
+src_prepare() {
+ HCFLAGS+=" -XBangPatterns" #fixes build failure on BE platforms; bug 466778
+
+ cabal_chdeps \
+ 'build-depends: process' 'build-depends: process, base'
+
+ for f in Scan Parser; do
+ rm "${S}/src/$f."*
+ mv "${S}/dist/build/alex/alex-tmp/$f.hs" "${S}"/src/
+ done
+
+ if use doc; then
+ cd "${S}/doc/"
+ eautoreconf || die "eautoreconf for docs failed"
+ fi
+}
+
+src_configure() {
+ haskell-cabal_src_configure
+
+ if use doc; then
+ cd "${S}/doc/"
+ econf || die "econf for docs failed"
+ fi
+}
+
+src_compile() {
+ cabal_src_compile
+
+ if use doc; then
+ emake -C "${S}/doc/" -j1 || die "emake for docs failed"
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ if use doc; then
+ doman "${S}/doc/alex.1"
+ dohtml -r "${S}/doc/alex/"
+ fi
+ dodoc README
+}