summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/getopt/files/getopt-1.1.4-irix.patch4
-rw-r--r--app-misc/getopt/files/getopt-1.1.5-libintl.patch4
-rw-r--r--app-misc/getopt/getopt-1.1.6-r1.ebuild62
3 files changed, 66 insertions, 4 deletions
diff --git a/app-misc/getopt/files/getopt-1.1.4-irix.patch b/app-misc/getopt/files/getopt-1.1.4-irix.patch
index 0c344a80131a..1fd38c3b0a20 100644
--- a/app-misc/getopt/files/getopt-1.1.4-irix.patch
+++ b/app-misc/getopt/files/getopt-1.1.4-irix.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/show_bug.cgi?id=211499
---- gnu/getopt.c.dist
-+++ gnu/getopt.c
+--- a/gnu/getopt.c
++++ b/gnu/getopt.c
@@ -69,12 +69,7 @@
#include <unistd.h>
#endif /* GNU C library. */
diff --git a/app-misc/getopt/files/getopt-1.1.5-libintl.patch b/app-misc/getopt/files/getopt-1.1.5-libintl.patch
index b40367105ed0..0b39b4ecbdc0 100644
--- a/app-misc/getopt/files/getopt-1.1.5-libintl.patch
+++ b/app-misc/getopt/files/getopt-1.1.5-libintl.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2012-12-28 11:40:09.524686698 +0100
-+++ Makefile 2012-12-28 11:41:20.646157275 +0100
+--- a/Makefile 2012-12-28 11:40:09.524686698 +0100
++++ b/Makefile 2012-12-28 11:41:20.646157275 +0100
@@ -61,7 +61,7 @@
-$(RM) $(objects) $(binaries)
diff --git a/app-misc/getopt/getopt-1.1.6-r1.ebuild b/app-misc/getopt/getopt-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..0acad8e55401
--- /dev/null
+++ b/app-misc/getopt/getopt-1.1.6-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="getopt(1) replacement supporting GNU-style long options"
+HOMEPAGE="http://frodo.looijaard.name/project/getopt/"
+SRC_URI="http://frodo.looijaard.name/system/files/software/getopt/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~m68k-mint ~ppc-aix ~ppc-macos ~sparc-solaris ~sparc64-solaris ~x64-cygwin ~x64-macos ~x64-solaris ~x86-fbsd ~x86-macos ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.5-libintl.patch
+ "${FILESDIR}"/${PN}-1.1.5-setlocale.patch
+ "${FILESDIR}"/${PN}-1.1.6-longrename.patch
+ "${FILESDIR}"/${PN}-1.1.4-irix.patch
+)
+
+src_compile() {
+ local nogettext="1"
+ local libintl=""
+ local libcgetopt=1
+
+ if use nls; then
+ nogettext=0
+ has_version sys-libs/glibc || libintl="-lintl"
+ fi
+
+ [[ ${CHOST} == *-aix* ]] && libcgetopt=0
+ [[ ${CHOST} == *-irix* ]] && libcgetopt=0
+ [[ ${CHOST} == *-interix* ]] && libcgetopt=0
+
+ emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" \
+ LIBCGETOPT=${libcgetopt} \
+ WITHOUT_GETTEXT=${nogettext} LIBINTL=${libintl} \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ use nls && emake prefix="${EPREFIX}/usr" DESTDIR="${D}" install_po
+
+ newbin getopt getopt-long
+
+ # at least on interix, the system getopt is ... broken...
+ # util-linux, which would provide the getopt binary, does not build &
+ # install on interix/prefix, so, this has to provide it.
+ [[ ${CHOST} == *-interix* || ${CHOST} == *-mint* ]] && \
+ dosym getopt-long /usr/bin/getopt
+
+ newman getopt.1 getopt-long.1
+
+ dodoc getopt-*sh
+}