summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/opencc/files/opencc-stop-copy.patch18
-rw-r--r--app-i18n/opencc/opencc-1.0.5.ebuild7
-rw-r--r--app-i18n/opencc/opencc-9999.ebuild7
3 files changed, 28 insertions, 4 deletions
diff --git a/app-i18n/opencc/files/opencc-stop-copy.patch b/app-i18n/opencc/files/opencc-stop-copy.patch
new file mode 100644
index 000000000000..4793951dd251
--- /dev/null
+++ b/app-i18n/opencc/files/opencc-stop-copy.patch
@@ -0,0 +1,18 @@
+We don't need this copy command on Linux (or other than Visual Studio
+build). Since it is colliding each other on parallel build, drop the
+command for now.
+
+See https://bugs.gentoo.org/666904
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index 1516775..2deb764 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -109,8 +109,6 @@ foreach(DICT ${DICTS})
+ ${DICT}.ocd
+ COMMENT
+ "Building ${DICT}.ocd"
+- COMMAND
+- ${CMAKE_COMMAND} -E copy "$<TARGET_FILE:libopencc>" "$<TARGET_FILE_DIR:${OPENCC_DICT_BIN}>"
+ COMMAND
+ ${OPENCC_DICT_BIN}
+ --input ${DICT_${DICT}_INPUT}
diff --git a/app-i18n/opencc/opencc-1.0.5.ebuild b/app-i18n/opencc/opencc-1.0.5.ebuild
index ba948e2bf80d..2ddcaab943f2 100644
--- a/app-i18n/opencc/opencc-1.0.5.ebuild
+++ b/app-i18n/opencc/opencc-1.0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -26,7 +26,10 @@ IUSE="doc test"
DEPEND="doc? ( app-doc/doxygen )"
DOCS="AUTHORS *.md"
-PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-test.patch
+ "${FILESDIR}"/${PN}-stop-copy.patch
+)
src_prepare() {
sed -i "s|\${DIR_SHARE_OPENCC}/doc|share/doc/${PF}|" doc/CMakeLists.txt
diff --git a/app-i18n/opencc/opencc-9999.ebuild b/app-i18n/opencc/opencc-9999.ebuild
index 9ec1cbd5d8b7..857d6dd70b8e 100644
--- a/app-i18n/opencc/opencc-9999.ebuild
+++ b/app-i18n/opencc/opencc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -26,7 +26,10 @@ IUSE="doc test"
DEPEND="doc? ( app-doc/doxygen )"
DOCS="AUTHORS *.md"
-PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-test.patch
+ "${FILESDIR}"/${PN}-stop-copy.patch
+)
src_prepare() {
sed -i "s|\${DIR_SHARE_OPENCC}/doc|share/doc/${PF}|" doc/CMakeLists.txt