summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/pariemacs')
-rw-r--r--app-emacs/pariemacs/pariemacs-3.14-r1.ebuild (renamed from app-emacs/pariemacs/pariemacs-3.14.ebuild)31
1 files changed, 16 insertions, 15 deletions
diff --git a/app-emacs/pariemacs/pariemacs-3.14.ebuild b/app-emacs/pariemacs/pariemacs-3.14-r1.ebuild
index aa608c9b7eaa..e94c56789e55 100644
--- a/app-emacs/pariemacs/pariemacs-3.14.ebuild
+++ b/app-emacs/pariemacs/pariemacs-3.14-r1.ebuild
@@ -1,38 +1,39 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit elisp
DESCRIPTION="sci-mathematics/pari emacs mode"
HOMEPAGE="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/"
+SRC_URI="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/latest-pari-distrib/${P}.tar.gz"
+S="${WORKDIR}"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-SRC_URI="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/latest-pari-distrib/${P}.tar.gz"
RDEPEND="sci-mathematics/pari"
DEPEND="${RDEPEND}"
-S="${WORKDIR}"
SITEFILE="64${PN}-gentoo.el"
DOCS="README CHANGES"
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
src_prepare() {
- eapply "${FILESDIR}"/${P}-makefile.patch
- eapply_user
- if [ -f /usr/share/doc/pari-*/pari.cfg ]; then
- cp /usr/share/doc/pari-*/pari.cfg .
- elif [ -f /usr/share/doc/pari-*/pari.cfg.bz2 ]; then
- cp /usr/share/doc/pari-*/pari.cfg.bz2 .
- bunzip2 pari.cfg.bz2
- else die "pari.cfg not found"
+ default
+ if [ -f /usr/share/pari/pari.cfg ]; then
+ cp /usr/share/pari/pari.cfg . || die
+ elif [ -f /usr/share/pari/pari.cfg.bz2 ]; then
+ cp /usr/share/pari/pari.cfg.bz2 . || die
+ bunzip2 pari.cfg.bz2 || die
+ else
+ die "pari.cfg not found"
fi
}
src_compile() {
- make pari-conf.el
- make elc
+ emake pari-conf.el
+ emake elc
}