summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/devmanual')
-rw-r--r--app-doc/devmanual/Manifest1
-rw-r--r--app-doc/devmanual/devmanual-0_pre20141116.ebuild58
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild52
-rw-r--r--app-doc/devmanual/metadata.xml12
4 files changed, 123 insertions, 0 deletions
diff --git a/app-doc/devmanual/Manifest b/app-doc/devmanual/Manifest
new file mode 100644
index 000000000000..ca1c05c49f6d
--- /dev/null
+++ b/app-doc/devmanual/Manifest
@@ -0,0 +1 @@
+DIST devmanual-0_pre20141116.tar.gz 169936 SHA256 1b24d4393f41981428db62d263195c724f105e6bf078debfe7fa2dad746b0413 SHA512 6af3f9a262bdb2ceb61ab195691dff4a850b22e8d1226e20ae3257c566b6cc913f756c8b90a40e8aa78b1242e78d24c4209a1d9cdb0706ae9b64c653544a028f WHIRLPOOL 54ed09c943bb570bee276f534119580ea312085d212342122adc671bd46333b312e3d769dc92359691fe1a3f0251f77c11678ddce23c0cdc5a8a875e9579a58d
diff --git a/app-doc/devmanual/devmanual-0_pre20141116.ebuild b/app-doc/devmanual/devmanual-0_pre20141116.ebuild
new file mode 100644
index 000000000000..f066ba9dd30a
--- /dev/null
+++ b/app-doc/devmanual/devmanual-0_pre20141116.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo
+
+[[ "${PV}" == "9999" ]] && inherit git-2
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="http://devmanual.gentoo.org/"
+if [[ "${PV}" == "9999" ]]; then
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
+else
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+fi
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+DEPEND="dev-libs/libxslt
+ media-gfx/imagemagick[truetype,svg,png]"
+
+DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ ${EPREFIX}/usr/share/doc/devmanual/html/index.html"
+
+src_compile() {
+ # Imagemagick uses inkscape (if present) to delegate
+ # svg conversions.
+ # Inkscape uses g_get_user_config_dir () which in turn
+ # uses XDG_CONFIG_HOME to get the config directory for this
+ # user. See bug 463380
+ export XDG_CONFIG_HOME="${T}/inkscape_home"
+ emake
+}
+
+src_install() {
+ dohtml -r *
+ einfo "Creating symlink from ${P} to ${PN} for preserving bookmarks"
+ dosym /usr/share/doc/${P} /usr/share/doc/${PN}
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version app-portage/eclass-manpages; then
+ elog "The offline version of the devmanual does not include the"
+ elog "documentation for the eclasses. If you need it, then emerge"
+ elog "the following package:"
+ elog
+ elog "app-portage/eclass-manpages"
+ elog
+ fi
+}
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
new file mode 100644
index 000000000000..eb83bf07ca3c
--- /dev/null
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-2 readme.gentoo
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="http://devmanual.gentoo.org/"
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-libs/libxslt
+ media-gfx/imagemagick[truetype,svg,png]"
+
+DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ /usr/share/doc/devmanual/html/index.html"
+
+src_compile() {
+ # Imagemagick uses inkscape (if present) to delegate
+ # svg conversions.
+ # Inkscape uses g_get_user_config_dir () which in turn
+ # uses XDG_CONFIG_HOME to get the config directory for this
+ # user. See bug 463380
+ export XDG_CONFIG_HOME="${T}/inkscape_home"
+ emake
+}
+
+src_install() {
+ dohtml -r *
+ einfo "Creating symlink from ${P} to ${PN} for preserving bookmarks"
+ dosym /usr/share/doc/${P} /usr/share/doc/${PN}
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version app-portage/eclass-manpages; then
+ elog "The offline version of the devmanual does not include the"
+ elog "documentation for the eclasses. If you need it, then emerge"
+ elog "the following package:"
+ elog
+ elog "app-portage/eclass-manpages"
+ elog
+ fi
+}
diff --git a/app-doc/devmanual/metadata.xml b/app-doc/devmanual/metadata.xml
new file mode 100644
index 000000000000..0d0a92f5f125
--- /dev/null
+++ b/app-doc/devmanual/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+<description>Bugs for the devmanual documentation must be assigned to
+devmanual@gentoo.org
+</description>
+</maintainer>
+</pkgmetadata>
+