summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/containers-common/containers-common-9999.ebuild16
-rw-r--r--app-containers/containers-common/files/examplify-mounts-conf.patch7
2 files changed, 11 insertions, 12 deletions
diff --git a/app-containers/containers-common/containers-common-9999.ebuild b/app-containers/containers-common/containers-common-9999.ebuild
index f2bba24b1975..73407d6e4994 100644
--- a/app-containers/containers-common/containers-common-9999.ebuild
+++ b/app-containers/containers-common/containers-common-9999.ebuild
@@ -17,11 +17,12 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-
+RESTRICT="test"
RDEPEND="
app-containers/containers-image
app-containers/containers-storage
app-containers/containers-shortnames
+ !<app-containers/podman-4.5.0-r1
net-firewall/nftables
net-firewall/iptables[nftables]
|| ( app-containers/crun app-containers/runc )
@@ -42,20 +43,13 @@ src_prepare() {
sed -i -e 's|/usr/local|/usr|g;' docs/Makefile || die
eapply "${FILESDIR}/fix-warnings.patch"
-}
-
-src_configure() {
- return
+ eapply "${FILESDIR}/examplify-mounts-conf.patch"
}
src_compile() {
emake docs
}
-src_test() {
- return
-}
-
src_install() {
emake DESTDIR="${D}" install
@@ -68,9 +62,7 @@ src_install() {
doins "${FILESDIR}/default.yaml"
insinto /usr/share/containers
- # https://github.com/containers/common/raw/main/pkg/seccomp/seccomp.json
- # https://github.com/containers/common/raw/main/pkg/subscriptions/mounts.conf
- doins "${FILESDIR}/seccomp.json" "${FILESDIR}/mounts.conf"
+ doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
}
diff --git a/app-containers/containers-common/files/examplify-mounts-conf.patch b/app-containers/containers-common/files/examplify-mounts-conf.patch
new file mode 100644
index 000000000000..eeaca09d5f1e
--- /dev/null
+++ b/app-containers/containers-common/files/examplify-mounts-conf.patch
@@ -0,0 +1,7 @@
+--- a/pkg/subscriptions/mounts.conf
++++ a/pkg/subscriptions/mounts.conf
+@@ -1 +1,3 @@
+-/usr/share/rhel/secrets:/run/secrets
++# Refer to containers-mounts.conf(5)
++# Example:
++# /usr/share/rhel/secrets:/run/secrets