summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/stress/stress-1.0.4-r1.ebuild')
-rw-r--r--app-benchmarks/stress/stress-1.0.4-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-benchmarks/stress/stress-1.0.4-r1.ebuild b/app-benchmarks/stress/stress-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..0df5cbf7eedd
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic
+
+MY_P=${PN}-${PV/_/}
+DESCRIPTION="Imposes stressful loads on different aspects of the system"
+HOMEPAGE="http://people.seas.harvard.edu/~apw/stress"
+SRC_URI="http://people.seas.harvard.edu/~apw/stress/${MY_P}.tar.gz -> ${MY_P}-r1.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ use static && append-ldflags -static
+}