summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unp/unp-2.0_pre7_p1-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-arch/unp/unp-2.0_pre7_p1-r1.ebuild b/app-arch/unp/unp-2.0_pre7_p1-r1.ebuild
index 1194f7d9dc89..97b3db7941e5 100644
--- a/app-arch/unp/unp-2.0_pre7_p1-r1.ebuild
+++ b/app-arch/unp/unp-2.0_pre7_p1-r1.ebuild
@@ -28,7 +28,11 @@ PATCHES=( "${FILESDIR}/${P}-remove-deprecated-have.diff" )
src_compile() {
if use nls; then
strip-linguas -i .
- emake -C po MOFILES="${LINGUAS// /.po }.po"
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.po }.po"
+ else
+ emake -C po
+ fi
fi
}
@@ -40,6 +44,10 @@ src_install() {
dobashcomp bash_completion.d/unp
if use nls; then
- emake -C po MOFILES="${LINGUAS// /.mo }.mo" DESTDIR="${D}" install
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.mo }.mo" DESTDIR="${D}" install
+ else
+ emake -C po DESTDIR="${D}" install
+ fi
fi
}