summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/orion/orion-1.4.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-video/orion/orion-1.4.0.ebuild b/media-video/orion/orion-1.4.0.ebuild
index 0bf1ef367d3d..804460e26d8f 100644
--- a/media-video/orion/orion-1.4.0.ebuild
+++ b/media-video/orion/orion-1.4.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit qmake-utils
+inherit qmake-utils eutils
DESCRIPTION="Cross-platform Twitch client"
HOMEPAGE="https://alamminsalo.github.io/orion/"
@@ -21,6 +21,14 @@ DEPEND="dev-qt/qtquickcontrols:5
RDEPEND="${DEPEND}
!mpv? ( media-plugins/gst-plugins-hls )"
+src_prepare() {
+ sed -i \
+ -e 's:^Icon=/usr/local/share/icons/orion.svg$:Icon=/usr/share/icons/hicolor/scalable/apps/orion.svg:' \
+ -e 's:^Categories=Games$:Categories=Game;:' \
+ distfiles/*.desktop
+ eapply_user
+}
+
src_configure() {
# TODO: also supports qtav, not yet in portage
local PLAYER