summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch12
-rw-r--r--app-office/gnucash/gnucash-3.7.ebuild5
2 files changed, 16 insertions, 1 deletions
diff --git a/app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch b/app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch
new file mode 100644
index 000000000000..c0e1778164cd
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/690270
+
+--- a/gnucash/register/register-gnome/CMakeLists.txt
++++ b/gnucash/register/register-gnome/CMakeLists.txt
+@@ -1,5 +1,7 @@
+ add_subdirectory(test)
+
++include(CheckSymbolExists)
++
+ #GTK before 3.14 didn't have GDK_MODIFIER_INTENT_DEFAULT_MOD_MASK
+ check_symbol_exists(GDK_MODIFIER_INTENT_DEFAULT_MOD_MASK gdk/gdktypes.h have_mod_mask)
+ if (NOT have_mod_mask)
diff --git a/app-office/gnucash/gnucash-3.7.ebuild b/app-office/gnucash/gnucash-3.7.ebuild
index ec42d91eaae7..4b8e26a831cd 100644
--- a/app-office/gnucash/gnucash-3.7.ebuild
+++ b/app-office/gnucash/gnucash-3.7.ebuild
@@ -80,7 +80,10 @@ PDEPEND="doc? (
gnome-extra/yelp
)"
-PATCHES=( "${FILESDIR}"/${PN}-3.2-no-gui.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-no-gui.patch
+ "${FILESDIR}"/${PN}-3.7-include-checksymbolexists.patch
+)
pkg_setup() {
use python && python-single-r1_pkg_setup