summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/fbzx/fbzx-3.0.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-emulation/fbzx/fbzx-3.0.0-r1.ebuild b/games-emulation/fbzx/fbzx-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..8fcb34dbfc9c
--- /dev/null
+++ b/games-emulation/fbzx/fbzx-3.0.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Full Screen Sinclair Spectrum emulator"
+HOMEPAGE="https://github.com/rastersoft/fbzx"
+SRC_URI="https://github.com/rastersoft/fbzx/archive/3.0.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[video]
+ media-sound/pulseaudio
+ media-libs/alsa-lib
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ sed -i -e "s|/usr/share/|/usr/share/${PN}/|g" src/llscreen.cpp || die
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ dobin src/fbzx
+ insinto "/usr/share/${PN}"
+ doins -r data/{keymap.bmp,spectrum-roms}
+ dodoc AMSTRAD CAPABILITIES FAQ PORTING README* TODO VERSIONS
+ doicon data/fbzx.svg
+ make_desktop_entry fbzx FBZX
+}