summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/linux-docs/Manifest1
-rw-r--r--sys-kernel/linux-docs/linux-docs-6.8.9.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/Manifest b/sys-kernel/linux-docs/Manifest
index b343d50ba6aa..63abfd740108 100644
--- a/sys-kernel/linux-docs/Manifest
+++ b/sys-kernel/linux-docs/Manifest
@@ -1 +1,2 @@
DIST linux-6.8.2.tar.xz 142512348 BLAKE2B f057c2512040600fbf0df67cf9c7200aee0c06b82b3cf749be8c5685844d2662a585ce17685c7af880c0d9dbbbd81302e5a1fa41c3dbd39869123121a0e82dc2 SHA512 6d23c2891d9e2512adfcc9882f01b4177942cca2a101860b7f6df7c608c645b6269e42afa85783f0c2897e414dbc2fd38af65c3bd9f60a3f71105cc2f6c229ed
+DIST linux-6.8.9.tar.xz 142582332 BLAKE2B 0305b6636a4e382855a2804cedc3984f1e891b26b24412e3533b1f29a07459d39be5121d4618da20098623290e922d502b7ac1b774f39e732f23a778a4b5b5be SHA512 67056eae13be9130e11ea7e4d394d1f0b6b1dccc4f080f72c136870d4486fdebc2c315d149ca4f1e57af4c79dedf849e31c439426166544691508edafca3d350
diff --git a/sys-kernel/linux-docs/linux-docs-6.8.9.ebuild b/sys-kernel/linux-docs/linux-docs-6.8.9.ebuild
new file mode 100644
index 000000000000..ff2813f4dd85
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-6.8.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10,11,12} )
+inherit linux-info python-any-r1 toolchain-funcs
+
+MY_P=linux-${PV}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/v6.x/${MY_P}.tar.xz"
+
+S=${WORKDIR}/${MY_P}
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="graphviz"
+
+RDEPEND="graphviz? ( >=media-gfx/graphviz-5.0.0 )"
+
+BDEPEND="${PYTHON_DEPS}
+ >=dev-python/sphinx-7.2.3
+ dev-python/sphinx-rtd-theme
+ media-libs/fontconfig
+ $(python_gen_any_dep '
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+ ')"
+
+src_prepare() {
+ default
+ # Fix the Python shebangs.
+ python_fix_shebang "${S}/Documentation/sphinx/"
+}
+
+src_compile() {
+ local ARCH="$(tc-arch-kernel)"
+ unset KBUILD_OUTPUT
+ HTML_DOCS=( Documentation/output/. )
+ emake htmldocs
+}
+
+src_install() {
+ einstalldocs
+}