summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/babelfish/babelfish-0.6.0-r1.ebuild (renamed from dev-python/babelfish/babelfish-0.6.0.ebuild)4
-rw-r--r--dev-python/babelfish/babelfish-9999.ebuild5
-rw-r--r--profiles/package.mask5
3 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/babelfish/babelfish-0.6.0.ebuild b/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
index 8cbe931148f3..69cb0c404508 100644
--- a/dev-python/babelfish/babelfish-0.6.0.ebuild
+++ b/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
@@ -5,6 +5,7 @@ EAPI=8
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1
DESCRIPTION="Python library to work with countries and languages"
@@ -19,4 +20,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+BDEPEND="
+ >=dev-python/pyproject2setuppy-20[${PYTHON_USEDEP}]"
+
distutils_enable_tests pytest
diff --git a/dev-python/babelfish/babelfish-9999.ebuild b/dev-python/babelfish/babelfish-9999.ebuild
index ae88fa30c838..8876693501c0 100644
--- a/dev-python/babelfish/babelfish-9999.ebuild
+++ b/dev-python/babelfish/babelfish-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
PYTHON_COMPAT=( python3_{8..10} )
@@ -15,4 +15,7 @@ EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
LICENSE="BSD"
SLOT="0"
+BDEPEND="
+ >=dev-python/pyproject2setuppy-20[${PYTHON_USEDEP}]"
+
distutils_enable_tests pytest
diff --git a/profiles/package.mask b/profiles/package.mask
index 1c1c73563a0d..11274cc18b8e 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -32,11 +32,6 @@
#--- END OF EXAMPLES ---
-# Michał Górny <mgorny@gentoo.org> (2021-08-16)
-# Broken ebuild that does not install data files. Masked until
-# pyproject2setuppy is fixed to handle the package correctly.
-=dev-python/babelfish-0.6.0
-
# Andreas K. Hüttel <dilfridge@gentoo.org> (2021-08-15)
# Broken since Perl 5.22, bug 662318. Removal in 30 days.
dev-perl/POE-API-Peek