summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/unidecode/unidecode-1.0.22.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/unidecode/unidecode-1.0.22.ebuild b/dev-python/unidecode/unidecode-1.0.22.ebuild
index af46dbffb7d1..fcf847f5df2d 100644
--- a/dev-python/unidecode/unidecode-1.0.22.ebuild
+++ b/dev-python/unidecode/unidecode-1.0.22.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
MY_PN=Unidecode
MY_P=${MY_PN}-${PV}
@@ -14,13 +14,13 @@ DESCRIPTION="Module providing ASCII transliterations of Unicode text"
HOMEPAGE="https://pypi.org/project/Unidecode/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
S=${WORKDIR}/${MY_P}
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
esetup.py test