summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xcalendar/files/xcalendar-4.0-clang16.patch40
-rw-r--r--x11-misc/xcalendar/files/xcalendar-4.0-implicits.patch22
-rw-r--r--x11-misc/xcalendar/xcalendar-4.0-r3.ebuild2
3 files changed, 41 insertions, 23 deletions
diff --git a/x11-misc/xcalendar/files/xcalendar-4.0-clang16.patch b/x11-misc/xcalendar/files/xcalendar-4.0-clang16.patch
new file mode 100644
index 000000000000..9e39901f9076
--- /dev/null
+++ b/x11-misc/xcalendar/files/xcalendar-4.0-clang16.patch
@@ -0,0 +1,40 @@
+https://bugs.gentoo.org/870484
+--- a/lists.c
++++ b/lists.c
+@@ -26,4 +26,5 @@
+ #include "xcalendar.h"
+
++int is_last(LList *list);
+
+ List
+@@ -150,5 +151,5 @@
+ }
+
+-is_last(list)
++int is_last(list)
+ LList *list;
+ {
+--- a/xcalendar.c
++++ b/xcalendar.c
+@@ -1168,5 +1168,5 @@
+ int m, y;
+ {
+- register d, i;
++ int d, i;
+
+ calInit = y;
+@@ -1217,5 +1217,5 @@
+ int yr;
+ {
+- register y, d;
++ int y, d;
+
+ /*
+--- a/xcalendar.h
++++ b/xcalendar.h
+@@ -38,4 +38,5 @@
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
diff --git a/x11-misc/xcalendar/files/xcalendar-4.0-implicits.patch b/x11-misc/xcalendar/files/xcalendar-4.0-implicits.patch
deleted file mode 100644
index 977ca96e572f..000000000000
--- a/x11-misc/xcalendar/files/xcalendar-4.0-implicits.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix implicit functions declarations
-
---- xcalendar/xcalendar.h
-+++ xcalendar/xcalendar.h
-@@ -37,6 +37,7 @@
-
-
- #include <stdio.h>
-+#include <stdlib.h>
- #include <X11/Xos.h>
- #include <X11/Xlib.h>
- #include <X11/Intrinsic.h>
---- xcalendar/lists.c
-+++ xcalendar/lists.c
-@@ -25,6 +25,7 @@
-
- #include "xcalendar.h"
-
-+is_last(LList *list);
-
- List
- CreateList(length, elementSize)
diff --git a/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild b/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild
index 509f954ff915..e400aa3e3cdc 100644
--- a/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild
+++ b/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild
@@ -29,7 +29,7 @@ DEPEND="
BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${P}-implicits.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {