summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/sh/sh-3.5.1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-util/sh/sh-3.5.1.ebuild b/dev-util/sh/sh-3.5.1.ebuild
index f5098aea771b..7da56df5263e 100644
--- a/dev-util/sh/sh-3.5.1.ebuild
+++ b/dev-util/sh/sh-3.5.1.ebuild
@@ -13,11 +13,25 @@ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar
LICENSE="Apache-2.0 BSD"
SLOT="0"
KEYWORDS="~amd64"
+IUSE="+man"
+
+BDEPEND="man? ( app-text/scdoc )"
+
+src_unpack() {
+ default
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ fi
+}
src_compile() {
# Not bothering with gosh for now as it's very new
# https://github.com/mvdan/sh#gosh
ego build ./cmd/shfmt
+ if use man; then
+ scdoc <cmd/shfmt/shfmt.1.scd >shfmt.1 || die "conversation of man page failed"
+ fi
}
src_test() {
@@ -27,4 +41,8 @@ src_test() {
src_install() {
dobin shfmt
+ if use man; then
+ doman shfmt.1
+ fi
+
}