summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/catkin_pkg/Manifest1
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.5.2.ebuild45
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild45
-rw-r--r--dev-python/catkin_pkg/files/catkin_prefix2.patch30
-rw-r--r--dev-python/catkin_pkg/files/infinite_loop5.patch27
-rw-r--r--dev-python/catkin_pkg/files/ros_packages.patch13
-rw-r--r--dev-python/catkin_pkg/metadata.xml12
-rw-r--r--profiles/package.mask1
8 files changed, 0 insertions, 174 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
deleted file mode 100644
index 08e672a1d448..000000000000
--- a/dev-python/catkin_pkg/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST catkin_pkg-0.5.2-gh.tar.gz 67596 BLAKE2B aec34c6f54926dee02034d542741affe9cb662b06b354062088bec1fec25381f036d59af5fa52153ba1ce1c91fdf8bb9d1484475df8a63268ca474a7acd5f285 SHA512 40e7e3839017ad430ee36dccf87a90727e5efd92e6c605cdba3e9f8850b71a6a80da79bd8760d94e356dadebdd842c8a3f8b530782fb75503d3e620add79be4a
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.5.2.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.5.2.ebuild
deleted file mode 100644
index 55a360027f71..000000000000
--- a/dev-python/catkin_pkg/catkin_pkg-0.5.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Standalone Python library for the catkin package system"
-HOMEPAGE="https://wiki.ros.org/catkin_pkg"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- !<dev-util/catkin-0.7.14"
-BDEPEND="
- test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/catkin_prefix2.patch"
- "${FILESDIR}/ros_packages.patch"
- "${FILESDIR}/infinite_loop5.patch"
-)
-
-distutils_enable_tests nose
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
deleted file mode 100644
index 55a360027f71..000000000000
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Standalone Python library for the catkin package system"
-HOMEPAGE="https://wiki.ros.org/catkin_pkg"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- !<dev-util/catkin-0.7.14"
-BDEPEND="
- test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/catkin_prefix2.patch"
- "${FILESDIR}/ros_packages.patch"
- "${FILESDIR}/infinite_loop5.patch"
-)
-
-distutils_enable_tests nose
diff --git a/dev-python/catkin_pkg/files/catkin_prefix2.patch b/dev-python/catkin_pkg/files/catkin_prefix2.patch
deleted file mode 100644
index 064ad1ca65f2..000000000000
--- a/dev-python/catkin_pkg/files/catkin_prefix2.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Allow CATKIN_PREFIX_PATH to work as CMAKE_PREFIX_PATH:
-When building with SYSROOT!=/, CMAKE_PREFIX_PATH is the same as with SYSROOT=/
-but we need to find packages in SYSROOT.
-
-Index: catkin_pkg-0.4.22/src/catkin_pkg/workspaces.py
-===================================================================
---- catkin_pkg-0.4.22.orig/src/catkin_pkg/workspaces.py
-+++ catkin_pkg-0.4.22/src/catkin_pkg/workspaces.py
-@@ -41,16 +41,17 @@ CATKIN_WORKSPACE_MARKER_FILE = '.catkin_
-
- def get_spaces(paths=None):
- """
-- Return a list of spaces based on the CMAKE_PREFIX_PATH or passed in list of workspaces.
-+ Return a list of spaces based on the CMAKE_PREFIX_PATH/CATKIN_PREFIX_PATH or passed in list of workspaces.
-
- It resolves the source space for each devel space and ignores non-catkin paths.
- :param paths_to_order: list of paths
- :param prefix_paths: list of prefixes, must not end with '/'
- """
- if paths is None:
-- if 'CMAKE_PREFIX_PATH' not in os.environ:
-- raise RuntimeError('Neither the environment variable CMAKE_PREFIX_PATH is set nor was a list of paths passed.')
-- paths = os.environ['CMAKE_PREFIX_PATH'].split(os.pathsep) if os.environ['CMAKE_PREFIX_PATH'] else []
-+ if 'CMAKE_PREFIX_PATH' not in os.environ and 'CATKIN_PREFIX_PATH' not in os.environ:
-+ raise RuntimeError('None of the environment variables CMAKE_PREFIX_PATH or CATKIN_PREFIX_PATH are set nor was a list of paths passed.')
-+ paths = os.environ['CMAKE_PREFIX_PATH'].split(os.pathsep) if os.environ.get('CMAKE_PREFIX_PATH') else []
-+ paths += os.environ['CATKIN_PREFIX_PATH'].split(os.pathsep) if os.environ.get('CATKIN_PREFIX_PATH') else []
-
- spaces = []
- for path in paths:
diff --git a/dev-python/catkin_pkg/files/infinite_loop5.patch b/dev-python/catkin_pkg/files/infinite_loop5.patch
deleted file mode 100644
index 7f88da41a27d..000000000000
--- a/dev-python/catkin_pkg/files/infinite_loop5.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=612860
-By Tim Rakowski
-We os.walk /usr with followlinks=True, but at least nodejs contains a "recursive" link in /usr/include/node
-
-Index: catkin_pkg-0.5.2/src/catkin_pkg/packages.py
-===================================================================
---- catkin_pkg-0.5.2.orig/src/catkin_pkg/packages.py
-+++ catkin_pkg-0.5.2/src/catkin_pkg/packages.py
-@@ -61,7 +61,9 @@ def find_package_paths(basepath, exclude
- """
- paths = []
- real_exclude_paths = [os.path.realpath(p) for p in exclude_paths] if exclude_paths is not None else []
-+ visited = set()
- for dirpath, dirnames, filenames in os.walk(basepath, followlinks=True):
-+ visited.add(dirpath)
- if set(dirnames + filenames) & ignore_markers or \
- os.path.realpath(dirpath) in real_exclude_paths or \
- (exclude_subspaces and '.catkin' in filenames):
-@@ -72,7 +74,7 @@ def find_package_paths(basepath, exclude
- del dirnames[:]
- continue
- # filter out hidden directories in-place
-- dirnames[:] = [d for d in dirnames if not d.startswith('.')]
-+ dirnames[:] = [d for d in dirnames if not d.startswith('.') and not os.path.realpath(os.path.join(dirpath, d)) in visited]
- return paths
-
-
diff --git a/dev-python/catkin_pkg/files/ros_packages.patch b/dev-python/catkin_pkg/files/ros_packages.patch
deleted file mode 100644
index 06933d69a9fa..000000000000
--- a/dev-python/catkin_pkg/files/ros_packages.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: catkin_pkg-0.3.1/src/catkin_pkg/packages.py
-===================================================================
---- catkin_pkg-0.3.1.orig/src/catkin_pkg/packages.py
-+++ catkin_pkg-0.3.1/src/catkin_pkg/packages.py
-@@ -59,7 +59,7 @@ def find_package_paths(basepath, exclude
- del dirnames[:]
- continue
- elif PACKAGE_MANIFEST_FILENAME in filenames:
-- paths.append(os.path.relpath(dirpath, basepath))
-+ paths.append(os.path.relpath(dirpath.replace('ros_packages/', ''), basepath))
- del dirnames[:]
- continue
- for dirname in dirnames:
diff --git a/dev-python/catkin_pkg/metadata.xml b/dev-python/catkin_pkg/metadata.xml
deleted file mode 100644
index 5bce740b417b..000000000000
--- a/dev-python/catkin_pkg/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ros-infrastructure/catkin_pkg</remote-id>
- <remote-id type="pypi">catkin-pkg</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index ae9503a9b56e..b713625e8e32 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -365,7 +365,6 @@ dev-python/ndg-httpsclient
acct-group/ros
acct-user/ros
dev-python/ament_package
-dev-python/catkin_pkg
# Michał Górny <mgorny@gentoo.org> (2022-12-23)
# Packages that still use dev-python/nose and have no revdeps.