summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/limnoria-plugins-progval/Manifest1
-rw-r--r--net-irc/limnoria-plugins-progval/limnoria-plugins-progval-20210523.ebuild38
-rw-r--r--net-irc/limnoria-plugins-progval/metadata.xml13
3 files changed, 52 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-progval/Manifest b/net-irc/limnoria-plugins-progval/Manifest
new file mode 100644
index 000000000000..12ae5d76760e
--- /dev/null
+++ b/net-irc/limnoria-plugins-progval/Manifest
@@ -0,0 +1 @@
+DIST limnoria-plugins-progval-20210523.tar.gz 4936882 BLAKE2B 3404d6d07f1d2e55357759000734df37566f2b9563149ea2efbcc2b4b3dbbc73e321280ee2846ed61df8b23400bcd8e1f5088921ffa1a77bf86625713c00aa98 SHA512 6a3b9d0c65070b8c6c4f762f273f4ebee37550c4aca00e82fc7232a957863aaff5bd5d1768eb8b00b40666b71f4d83ec6253d0f42132ebf7563208aadaacd48d
diff --git a/net-irc/limnoria-plugins-progval/limnoria-plugins-progval-20210523.ebuild b/net-irc/limnoria-plugins-progval/limnoria-plugins-progval-20210523.ebuild
new file mode 100644
index 000000000000..102b8797f770
--- /dev/null
+++ b/net-irc/limnoria-plugins-progval/limnoria-plugins-progval-20210523.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="8781713a715800e8ba535ce2525d1441b3702bcb"
+
+DESCRIPTION="Collection of plugins for Supybot/Limnoria I wrote or forked."
+HOMEPAGE="https://github.com/ProgVal/Supybot-plugins"
+SRC_URI="https://github.com/ProgVal/Supybot-plugins/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2 GPL-3 MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="net-irc/limnoria"
+
+DOCS=(
+ "README.md"
+ "requirements.txt"
+)
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/ProgVal
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before this plugin can be used, your bot will need to be told where to"
+ elog "load it from. To do this, add /usr/share/limnoria-extra-plugins/ncoevoet when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/ProgVal"
+}
diff --git a/net-irc/limnoria-plugins-progval/metadata.xml b/net-irc/limnoria-plugins-progval/metadata.xml
new file mode 100644
index 000000000000..a50d04aabdda
--- /dev/null
+++ b/net-irc/limnoria-plugins-progval/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>wraeth@gentoo.org</email>
+ <name>Sam Jorna</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">ProgVal/Supybot-plugins</remote-id>
+ <bugs-to>https://github.com/ProgVal/Supybot-plugins/issues</bugs-to>
+ </upstream>
+</pkgmetadata>