summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch23
-rw-r--r--dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild2
2 files changed, 13 insertions, 12 deletions
diff --git a/dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch b/dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch
index c0f07eac494f..ac696c40710f 100644
--- a/dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch
+++ b/dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch
@@ -1,27 +1,28 @@
-From: Arthur Zamarin <arthurzam@gentoo.org>
-
-Simplify dependencies used for metadata generation.
-
+diff --git a/pyproject.toml b/pyproject.toml
+index c5bd914c0..3757e983b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -19,7 +19,7 @@
# IN THE SOFTWARE.
-
+
[build-system]
-requires = ["hatchling", "hatch-requirements-txt", "hatch-nodejs-version>=0.3.0"]
+requires = ["hatchling"]
build-backend = "hatchling.build"
-
+
[project]
-@@ -55,10 +55,7 @@ tags = "material.plugins.tags.plugin:TagsPlugin"
+@@ -55,13 +55,7 @@ tags = "material.plugins.tags.plugin:TagsPlugin"
material = "material"
-
+
[tool.hatch.version]
-source = "nodejs"
-
-[tool.hatch.metadata.hooks.nodejs]
-fields = ["license", "description", "authors", "keywords", "urls"]
+-
+-[tool.hatch.metadata.hooks.requirements_txt]
+-filename = "requirements.txt"
+path = "gentoo_version.py"
-
- [tool.hatch.metadata.hooks.requirements_txt]
- filename = "requirements.txt"
+
+ [tool.hatch.build.targets.wheel]
+ include = ["/material"]
diff --git a/dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild b/dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild
index 4f1e1fca0123..2071af80ea70 100644
--- a/dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild
+++ b/dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild
@@ -45,7 +45,7 @@ PATCHES=(
"${FILESDIR}/${PN}-8.5.7-simplify-build.patch"
)
-_src_prepare() {
+src_prepare() {
echo "__version__ = '${PV}'"> gentoo_version.py || die
distutils-r1_src_prepare
}