summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild18
-rw-r--r--dev-haskell/hdbc-sqlite3/metadata.xml5
2 files changed, 7 insertions, 16 deletions
diff --git a/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
index 6f71fc5a2a92..5cb19571040f 100644
--- a/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
+++ b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# ebuild generated by hackport 0.5.1
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -buildtests
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
@@ -18,27 +19,22 @@ SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="buildtests +splitbase"
+IUSE="+splitbase"
RDEPEND=">=dev-db/sqlite-3.0
>=dev-haskell/hdbc-2.3.0.0:2=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
- buildtests? ( dev-haskell/convertible:=[profile?]
- dev-haskell/hunit:=[profile?]
- dev-haskell/old-locale:=[profile?]
- dev-haskell/old-time:=[profile?]
- dev-haskell/testpack:=[profile?] )
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.2.3
+ >=dev-haskell/cabal-1.2
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag buildtests buildtests) \
+ --flag=-buildtests \
$(cabal_flag splitbase splitbase)
}
diff --git a/dev-haskell/hdbc-sqlite3/metadata.xml b/dev-haskell/hdbc-sqlite3/metadata.xml
index a6dc7b001d95..b9f67a8436a4 100644
--- a/dev-haskell/hdbc-sqlite3/metadata.xml
+++ b/dev-haskell/hdbc-sqlite3/metadata.xml
@@ -6,13 +6,8 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="buildtests">Build the executable to run unit tests</flag>
<flag name="splitbase">Choose the new smaller, split-up package.</flag>
</use>
- <longdescription>
- This is the Sqlite v3 driver for HDBC, the generic
- database access system for Haskell
- </longdescription>
<upstream>
<remote-id type="github">hdbc/hdbc-sqlite3</remote-id>
</upstream>