summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.8-r2.ebuild7
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.8-r3.ebuild9
2 files changed, 13 insertions, 3 deletions
diff --git a/net-p2p/rtorrent/rtorrent-0.9.8-r2.ebuild b/net-p2p/rtorrent/rtorrent-0.9.8-r2.ebuild
index bc460bab122e..cc07aef717a8 100644
--- a/net-p2p/rtorrent/rtorrent-0.9.8-r2.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.9.8-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools linux-info systemd
+inherit autotools flag-o-matic linux-info systemd
DESCRIPTION="BitTorrent Client using libtorrent"
HOMEPAGE="https://rakshasa.github.io/rtorrent/"
@@ -56,6 +56,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/861848
+ # https://github.com/rakshasa/rtorrent/issues/1264
+ filter-lto
+
default
# configure needs bash or script bombs out on some null shift, bug #291229
diff --git a/net-p2p/rtorrent/rtorrent-0.9.8-r3.ebuild b/net-p2p/rtorrent/rtorrent-0.9.8-r3.ebuild
index f2faf7732600..955a5c7770a9 100644
--- a/net-p2p/rtorrent/rtorrent-0.9.8-r3.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.9.8-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools linux-info systemd
+inherit autotools flag-o-matic linux-info systemd
DESCRIPTION="BitTorrent Client using libtorrent"
HOMEPAGE="https://rakshasa.github.io/rtorrent/"
@@ -57,6 +57,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/861848
+ # https://github.com/rakshasa/rtorrent/issues/1264
+ filter-lto
+
# configure needs bash or script bombs out on some null shift, bug #291229
CONFIG_SHELL=${BASH} econf \
$(use_enable debug) \