summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild (renamed from dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild)17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild
index dd721a85f55e..2647980b40b1 100644
--- a/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild
+++ b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=6
-inherit php-pear-r1
+inherit php-pear-r2
DESCRIPTION="Implementation of Hashed Message Authentication Code for PHP5"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
+DEPEND="test? ( dev-php/PEAR-PEAR dev-php/phpunit )"
+HTML_DOCS=( docs/intro.xml )
-src_install() {
- php-pear-r1_src_install
-
- #Useless file that often conflicts with other packages
- rm "${D}/usr/share/php/generate_package_xml.php"
+src_test() {
+ phpunit tests || die
}
pkg_postinst() {