summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/vgrep/vgrep-2.5.1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/app-text/vgrep/vgrep-2.5.1.ebuild b/app-text/vgrep/vgrep-2.5.1.ebuild
index 6b7efaf86cf6..9ee18dfc15b3 100644
--- a/app-text/vgrep/vgrep-2.5.1.ebuild
+++ b/app-text/vgrep/vgrep-2.5.1.ebuild
@@ -13,23 +13,18 @@ LICENSE="BSD GPL-3+ MIT MIT-with-advertising"
SLOT="0"
KEYWORDS="~amd64"
-# Uses golangci-lint
-RESTRICT="test"
+# golangci-lint is required to run tests which is not yet packaged
+RESTRICT="strip test"
BDEPEND="dev-go/go-md2man"
DOCS=( README.md )
-# go binary
-QA_PRESTRIPPED="usr/bin/vgrep"
-
src_compile() {
emake build
}
src_install() {
- local prefix="${D}/usr"
- mkdir -p "${prefix}"/bin || die
-
- emake PREFIX="${prefix}" install
+ emake PREFIX="${D}/usr" install
+ einstalldocs
}