summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cysignals/Manifest1
-rw-r--r--dev-python/cysignals/cysignals-1.12.3.ebuild32
-rw-r--r--dev-python/pytest-lazy-fixtures/Manifest1
-rw-r--r--dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.1.2.ebuild31
-rw-r--r--dev-python/referencing/Manifest1
-rw-r--r--dev-python/referencing/referencing-0.36.2.ebuild36
6 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/cysignals/Manifest b/dev-python/cysignals/Manifest
index 2380a22c410c..b2ce54145c45 100644
--- a/dev-python/cysignals/Manifest
+++ b/dev-python/cysignals/Manifest
@@ -1 +1,2 @@
DIST cysignals-1.12.2.tar.gz 65828 BLAKE2B dff532fb0c95abe53331082c88f79edd3a7136501c2015272d83e0a5d29b51e26c007b06f3e4ead42eaa306c1219ccc207827dc58ff954514ebd7fdc47dd2d02 SHA512 9cbf3eb4a11724949f513b4409d136b0890f987f9a5d3c3324b12bddd85eb7226dd793a5b2ec383e9ee46fa59e55f9ca19b0fb4c02e0b6eab46e01607668a8cb
+DIST cysignals-1.12.3.tar.gz 65536 BLAKE2B c01a39d9803f8ff260b892187766d11423c72d2941bfc97671c0315ad57024a4fabe995a947a0b21b242e3ea5d27f353d04ae4489838017f27cc74708900b558 SHA512 fb17848d26b274d4d94461cb0542e91361ee196640bdc6888984940a4485a1118ece36db8efeb49e9df5477114038bcbc8b92f465aa81fd7c706455419532e5d
diff --git a/dev-python/cysignals/cysignals-1.12.3.ebuild b/dev-python/cysignals/cysignals-1.12.3.ebuild
new file mode 100644
index 000000000000..3bb2a58f033b
--- /dev/null
+++ b/dev-python/cysignals/cysignals-1.12.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Interrupt and signal handling for Cython"
+HOMEPAGE="
+ https://github.com/sagemath/cysignals/
+ https://pypi.org/project/cysignals/
+"
+
+# setup.py has "or later"
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+BDEPEND="
+ >=dev-python/cython-3.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/pytest-lazy-fixtures/Manifest b/dev-python/pytest-lazy-fixtures/Manifest
index 5716cc075fca..9e8914533f66 100644
--- a/dev-python/pytest-lazy-fixtures/Manifest
+++ b/dev-python/pytest-lazy-fixtures/Manifest
@@ -1 +1,2 @@
DIST pytest_lazy_fixtures-1.1.1.tar.gz 6978 BLAKE2B 975f76783a224c5f1237546108c25936a3fc5f6f466e936f506957675f220cf200dd0bb4f516e361fb56795281951b4196e1e7f1f399bf15dd9337766eb611a0 SHA512 b8b215f16414ddfd2f6c16b1eb8f10cc6b9931ff44f7a0a158e721071160d94e550336e785d1b5ab772ccc2a88c08687c3e5bdcf684c5e496630f341ba8b423d
+DIST pytest_lazy_fixtures-1.1.2.tar.gz 7231 BLAKE2B e3754f48501cc1908af4b733a40adb948926800d7921addb8510eeddb44c613cb80ed00044a5cef45145d8bc2c3ebda31c536facc1a4db11cdf7d8f1ef5250e9 SHA512 f9c80c77c6ea72f31817e42eab54816aefab5dade1a56ba335bc95e64ad3b48abf44f8e86c8c4c19b83bc1f51c4c15d1256df97ab9db20ee9a1266362b94f679
diff --git a/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.1.2.ebuild b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.1.2.ebuild
new file mode 100644
index 000000000000..d133e84e3f6b
--- /dev/null
+++ b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Allows you to use fixtures in @pytest.mark.parametrize"
+HOMEPAGE="
+ https://github.com/dev-petrov/pytest-lazy-fixtures/
+ https://pypi.org/project/pytest-lazy-fixtures/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_lazy_fixtures.plugin
+ epytest
+}
diff --git a/dev-python/referencing/Manifest b/dev-python/referencing/Manifest
index dac9b5104837..6c466cf5f905 100644
--- a/dev-python/referencing/Manifest
+++ b/dev-python/referencing/Manifest
@@ -1,2 +1,3 @@
DIST referencing-0.35.1.tar.gz 62991 BLAKE2B b434d3b24bb01c7ea2b97300408571483ecfaa49b52867374a8734b4dafd06404c8b993757620329668fa01eb791c2a6f938aa4be20ff841fe691a4b47dcf6b3 SHA512 b737afb45bfb1adb91f457b78ab4a31a6f33839ef61095663fd66d91c09fc379d900f778bacaa36722770ce80eccd6a227a074cb44836e69205bed06165d033d
DIST referencing-0.36.1.tar.gz 74661 BLAKE2B a5eb713a0f227f4e331169e7aed7691d12712279ce3851cc58da87e7ba41ba291a80066360f7d6fc6f5e170977ae1718717438c7383c9e33bfc0a14f30e4c805 SHA512 2e2cbe9614811a650cd1dd6a63dd42ddb152ed934e9f3cb93671965ae66b982d7fc5207412f3c3fc4216727cc54499c9a39102e20dfc6d6a668a5d5d4c3ec604
+DIST referencing-0.36.2.tar.gz 74744 BLAKE2B 82a789f41710b064c06adaefd15cc5f6780731169f6eacc0c0ef6e6ef0e0a1e5e281a5d6eb24eb3570327dcca3ddfb8de74dd179f1458789fa1d4d90a5bb67a0 SHA512 fa47a5d2f23390d6eba01ed946f6542eb4d281eed754547141e7c18b10a4c41f960e1c5ff8c4aaf0f282877f4b3d9efd0dbfb7f145c12dd7acc84ac8486864ca
diff --git a/dev-python/referencing/referencing-0.36.2.ebuild b/dev-python/referencing/referencing-0.36.2.ebuild
new file mode 100644
index 000000000000..9f96720001ad
--- /dev/null
+++ b/dev-python/referencing/referencing-0.36.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Cross-specification JSON referencing (JSON Schema, OpenAPI...)"
+HOMEPAGE="
+ https://github.com/python-jsonschema/referencing/
+ https://pypi.org/project/referencing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
+ ' 3.{10..12})
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest