summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-04-08 00:04:04 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-04-08 00:04:04 +0100
commit08544d9afaff2107bc9ec6ee919371a3f41df44f (patch)
tree9b4d13cffa90856c2324693a32f3c21897746410 /x11-wm
parentx11-wm/xpra: Version bump to 4.1.2 (diff)
downloadgentoo-08544d9afaff2107bc9ec6ee919371a3f41df44f.tar.gz
gentoo-08544d9afaff2107bc9ec6ee919371a3f41df44f.tar.bz2
gentoo-08544d9afaff2107bc9ec6ee919371a3f41df44f.zip
x11-wm/xpra: Fix udev rule installation path
Although /usr/lib/udev is mentioned in udev's documentation, Gentoo typically uses /lib/udev so move the directory. Closes: https://bugs.gentoo.org/777867 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xpra/xpra-4.1.2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-wm/xpra/xpra-4.1.2.ebuild b/x11-wm/xpra/xpra-4.1.2.ebuild
index 65e293302714..cde55d551959 100644
--- a/x11-wm/xpra/xpra-4.1.2.ebuild
+++ b/x11-wm/xpra/xpra-4.1.2.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_SINGLE_IMPL=yes
DISTUTILS_USE_SETUPTOOLS=no
-inherit xdg distutils-r1 tmpfiles prefix
+inherit xdg distutils-r1 tmpfiles prefix udev
DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
HOMEPAGE="https://xpra.org/"
@@ -157,3 +157,12 @@ python_configure_all() {
export XPRA_SOCKET_DIRS="${EPREFIX}/run/xpra"
}
+
+python_install_all() {
+ distutils-r1_python_prepare_all
+
+ # Move udev dir to the right place.
+ local dir=$(get_udevdir)
+ dodir "${dir%/*}"
+ mv -vnT "${ED}"/usr/lib/udev "${ED}${dir}" || die
+}