summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:28:29 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:05 -0400
commit1e7d9f5c6bc522d362d37105761235fcc67fea7c (patch)
tree4ac03624d545a94a42546ed1b13a7faa0567cae1 /x11-wm/lwm
parentx11-wm/larswm: pass -std=gnu89 (diff)
downloadgentoo-1e7d9f5c6bc522d362d37105761235fcc67fea7c.tar.gz
gentoo-1e7d9f5c6bc522d362d37105761235fcc67fea7c.tar.bz2
gentoo-1e7d9f5c6bc522d362d37105761235fcc67fea7c.zip
x11-wm/lwm: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-wm/lwm')
-rw-r--r--x11-wm/lwm/lwm-1.2.4.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/x11-wm/lwm/lwm-1.2.4.ebuild b/x11-wm/lwm/lwm-1.2.4.ebuild
index e1d55b18003d..27cd77886906 100644
--- a/x11-wm/lwm/lwm-1.2.4.ebuild
+++ b/x11-wm/lwm/lwm-1.2.4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="The ultimate lightweight window manager"
HOMEPAGE="https://www.jfc.org.uk/software/lwm.html"
@@ -32,6 +32,8 @@ src_prepare() {
}
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}