summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-30 09:05:58 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-30 09:27:00 +0200
commita824e8eed73acf892b185ba0ddf47810d802a95d (patch)
tree735a8b81af57b1f377465a7695fd2234f1acb377 /x11-themes
parentx11-themes/goddard-backgrounds: EAPI bump, bug 605728 (diff)
downloadgentoo-a824e8eed73acf892b185ba0ddf47810d802a95d.tar.gz
gentoo-a824e8eed73acf892b185ba0ddf47810d802a95d.tar.bz2
gentoo-a824e8eed73acf892b185ba0ddf47810d802a95d.zip
x11-themes/constantine-backgrounds: EAPI bump, bug 605728
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r1.ebuild b/x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r1.ebuild
new file mode 100644
index 000000000000..1d9a23937f3b
--- /dev/null
+++ b/x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator rpm
+
+SRC_PATH=development/15/source/SRPMS
+FEDORA=15
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Fedora official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F12_Artwork"
+
+SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm"
+
+LICENSE="CC-BY-SA-2.0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+
+src_unpack() {
+ rpm_src_unpack
+
+ # as of 2017-07-28 rpm.eclass does not unpack the further lzma
+ # file automatically.
+ unpack ./${MY_P}.tar.lzma
+}
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ # The install targets are serial anyway.
+ emake -j1 DESTDIR="${D}" install
+}