summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-10-20 14:09:11 +0200
committerPacho Ramos <pacho@gentoo.org>2023-10-20 15:14:37 +0200
commitd7ef938dd28447d8817392267801784b5987ad77 (patch)
tree5bf1326286b98fda28ceb30415693f3e117e3722 /x11-themes
parentapp-office/onlyoffice-bin: add 7.5.0 (diff)
downloadgentoo-d7ef938dd28447d8817392267801784b5987ad77.tar.gz
gentoo-d7ef938dd28447d8817392267801784b5987ad77.tar.bz2
gentoo-d7ef938dd28447d8817392267801784b5987ad77.zip
x11-themes/QGnomePlatform: Set variable only on GNOME
Closes: https://bugs.gentoo.org/915620 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.9.2-r3.ebuild44
-rw-r--r--x11-themes/QGnomePlatform/files/90-qgnomeplatform6
2 files changed, 50 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.9.2-r3.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.2-r3.ebuild
new file mode 100644
index 000000000000..116c574669c6
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.2-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="minimal wayland"
+
+RDEPEND="
+ dev-qt/qtdbus:5=
+ >=dev-qt/qtquickcontrols2-5.15.2:5=
+ >=dev-qt/qtwidgets-5.15.2:5=
+ !minimal? ( kde-frameworks/qqc2-desktop-style:5= )
+ wayland? ( dev-qt/qtwayland:5= )
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/xdg-desktop-portal
+ x11-libs/gtk+:3
+ >=x11-themes/adwaita-qt-1.4.2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ -DDISABLE_DECORATION_SUPPORT="$(usex wayland false true)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # https://github.com/FedoraQt/QGnomePlatform/pull/150#issuecomment-1689693729
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/90-qgnomeplatform"
+}
diff --git a/x11-themes/QGnomePlatform/files/90-qgnomeplatform b/x11-themes/QGnomePlatform/files/90-qgnomeplatform
new file mode 100644
index 000000000000..6496e6890e2c
--- /dev/null
+++ b/x11-themes/QGnomePlatform/files/90-qgnomeplatform
@@ -0,0 +1,6 @@
+#!/bin/sh
+case "$XDG_CURRENT_DESKTOP" in
+ *GNOME*)
+ export QT_QPA_PLATFORMTHEME=qgnomeplatform
+ ;;
+esac