summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmdl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmdl')
-rw-r--r--x11-plugins/wmdl/Manifest1
-rw-r--r--x11-plugins/wmdl/files/makefile.diff44
-rw-r--r--x11-plugins/wmdl/metadata.xml5
-rw-r--r--x11-plugins/wmdl/wmdl-1.4.1.ebuild36
4 files changed, 86 insertions, 0 deletions
diff --git a/x11-plugins/wmdl/Manifest b/x11-plugins/wmdl/Manifest
new file mode 100644
index 000000000000..54c8463bd70e
--- /dev/null
+++ b/x11-plugins/wmdl/Manifest
@@ -0,0 +1 @@
+DIST wmdl-1.4.1.tar.gz 45557 RMD160 d01afe58fb568933e6cc70e4c802a194396cd72c SHA1 837e82a7ea66233ec6e08bb939268e47bd114de8 SHA256 69593b4f6180de327673dac1be399de5c778f21d6355d24ed9d7a672fa8ce4ba
diff --git a/x11-plugins/wmdl/files/makefile.diff b/x11-plugins/wmdl/files/makefile.diff
new file mode 100644
index 000000000000..90491b7a93e9
--- /dev/null
+++ b/x11-plugins/wmdl/files/makefile.diff
@@ -0,0 +1,44 @@
+diff -urN wmdl-1.4.1/Makefile wmdl-1.4.1-modified/Makefile
+--- Makefile 2009-04-28 16:34:24.000000000 +0200
++++ Makefile.new 2009-04-28 16:33:55.000000000 +0200
+@@ -1,23 +1,14 @@
+
+-INCLUDES = -I/usr/include \
+- -I/usr/local/include \
+- -I/usr/openwin/share/include/X11
+-
+-LIBINC = -L/usr/lib/X11 \
+- -L/usr/X11/lib \
+- -L/usr/X11R6/lib \
+- -L/usr/local/lib/X11
++INCLUDES =
++
++LIBINC = -L/usr/X11R6/lib
+
+ PIXMAPINC = -I./images
+
+ LIBS = -lm -lX11 -lXpm -lXext
+
+
+-CC=gcc
+-#CC=cc
+-
+-#CFLAGS= -g --verbose
+-CFLAGS= -g
++FLAGS=${CFLAGS}
+
+ TARGET=wmdl
+ SOURCE=wmdl.c
+@@ -25,10 +16,10 @@
+ all: ${TARGET}
+
+ ${TARGET}: ${SOURCE}
+- $(CC) $(CFLAGS) -o ${TARGET} ${SOURCE} ${INCLUDES} ${LIBINC} ${PIXMAPINC} ${LIBS}
++ $(CC) $(FLAGS) -o ${TARGET} ${SOURCE} ${INCLUDES} ${LIBINC} ${PIXMAPINC} ${LIBS}
+
+ clean:
+ if [ -e wmdl ] ; then rm wmdl; fi
+
+ install:
+- if [ -e /usr/local/bin ] ; then cp wmdl /usr/local/bin ; fi
++ if [ -e /usr/bin ] ; then cp wmdl /usr/bin ; fi
diff --git a/x11-plugins/wmdl/metadata.xml b/x11-plugins/wmdl/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmdl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmdl/wmdl-1.4.1.ebuild b/x11-plugins/wmdl/wmdl-1.4.1.ebuild
new file mode 100644
index 000000000000..8e0b6d8e8111
--- /dev/null
+++ b/x11-plugins/wmdl/wmdl-1.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="WindowMaker Doom Load dockapp"
+HOMEPAGE="http://the.homepage.doesnt.appear.to.exist.anymore.com"
+SRC_URI="http://www.ibiblio.org/pub/linux/distributions/gentoo/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/makefile.diff
+
+}
+
+src_compile() {
+ emake FLAGS="${CFLAGS} ${LDFLAGS}" || die "parallel make failed"
+}
+
+src_install() {
+ dobin wmdl || die "dobin failed."
+}