summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2023-05-10 12:21:35 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-05-20 15:50:06 +0300
commit86005ddb9e7a8c82101ac0a5957c30fe5a8803b1 (patch)
tree29fc4887cde2e8ff5513f65b2ec947f2ca43313f /x11-misc/stalonetray
parentnet-p2p/kubo: add 0.20.0 (diff)
downloadgentoo-86005ddb9e7a8c82101ac0a5957c30fe5a8803b1.tar.gz
gentoo-86005ddb9e7a8c82101ac0a5957c30fe5a8803b1.tar.bz2
gentoo-86005ddb9e7a8c82101ac0a5957c30fe5a8803b1.zip
x11-misc/stalonetray: add 0.8.5
Closes: https://bugs.gentoo.org/898848 Closes: https://891183.bugs.gentoo.org/attachment.cgi?id=848715 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/stalonetray')
-rw-r--r--x11-misc/stalonetray/Manifest1
-rw-r--r--x11-misc/stalonetray/stalonetray-0.8.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/stalonetray/Manifest b/x11-misc/stalonetray/Manifest
index da63190eaebf..eac5b685ec28 100644
--- a/x11-misc/stalonetray/Manifest
+++ b/x11-misc/stalonetray/Manifest
@@ -1 +1,2 @@
DIST stalonetray-0.8.4.tar.gz 94614 BLAKE2B 4def696bbd580960f2d7fd84516658e4b4112b40989523840566d34dac71ba92e3adf021796059db919515cc978ac0c5d7783a4ed41aa9f82c8cbcfd00bc958b SHA512 3afdeb7794171f490c5eca631c574003a00bbed863b9caf4024e1b064772d3c24ea3836f280eeab1d50def67928f4d08d3d375047f43bcc39f16a3250015ff2b
+DIST stalonetray-0.8.5.tar.gz 102899 BLAKE2B abf70916cb762041c5eaaa3faaa3e96a89f0aa31bd72f285209bb29cc5138f2517d1fa00fda1c39da5ca12028b2e78a813fd15d62dfe7c6d312da52559eb3a2d SHA512 7fe1c2fcc5de06b89f4a5c182baeb0a98f0328ae6bf03a79e76c4af7ee4d86cd8f6967ec8b0123a831998cb075ef2b2f6bc6478bde0b73883fe37d2bd6a471d3
diff --git a/x11-misc/stalonetray/stalonetray-0.8.5.ebuild b/x11-misc/stalonetray/stalonetray-0.8.5.ebuild
new file mode 100644
index 000000000000..8848afa772cb
--- /dev/null
+++ b/x11-misc/stalonetray/stalonetray-0.8.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="System tray utility including support for KDE system tray icons"
+HOMEPAGE="https://kolbusa.github.io/stalonetray/"
+SRC_URI="https://github.com/kolbusa/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="debug +graceful-exit"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="app-text/docbook-xml-dtd
+ dev-libs/libxslt"
+
+DOCS=( AUTHORS BUGS COPYING NEWS README.md TODO stalonetrayrc.sample stalonetray.html )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable graceful-exit) \
+ --enable-native-kde
+}
+
+src_compile() {
+ emake
+ emake dist
+}