summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/ipager/ipager-1.1.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/ipager/ipager-1.1.0.ebuild')
-rw-r--r--x11-misc/ipager/ipager-1.1.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/ipager/ipager-1.1.0.ebuild b/x11-misc/ipager/ipager-1.1.0.ebuild
new file mode 100644
index 000000000000..6c15920edc90
--- /dev/null
+++ b/x11-misc/ipager/ipager-1.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="A themable desktop pager for fluxbox and other window managers"
+HOMEPAGE="http://www.useperl.ru/ipager/index.en.html"
+SRC_URI="http://www.useperl.ru/ipager/src/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xinerama"
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libXmu
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-scons_imlib2.patch
+ epatch "${FILESDIR}"/${P}-scons_flags.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_compile() {
+ CONFIG_OPTS="xinerama=false"
+ use xinerama && CONFIG_OPTS="${CONFIG_OPTS} xinerama=true"
+ # FYI: Passing debug=true only adds -ggdb inside the SConstruct
+
+ scons \
+ --cache-disable \
+ PREFIX="/usr" \
+ ${CONFIG_OPTS} \
+ || die "scons configure failed"
+}
+
+src_install() {
+ scons \
+ --cache-disable \
+ PREFIX="/usr" \
+ DESTDIR="${D}" \
+ install \
+ || die "scons install failed"
+ dodoc ToDo ChangeLog README
+ dodoc themes/*.conf
+}