summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-04-16 14:35:35 +0200
committerDavid Seifert <soap@gentoo.org>2023-04-16 14:35:35 +0200
commitbc1205168b490c181cc54a43fb97c7e89b19835d (patch)
treead5eb9f22311b1012cbc42253459a990d4d66f30 /x11-misc/gromit
parentx11-misc/grabc: update EAPI 6 -> 8 (diff)
downloadgentoo-bc1205168b490c181cc54a43fb97c7e89b19835d.tar.gz
gentoo-bc1205168b490c181cc54a43fb97c7e89b19835d.tar.bz2
gentoo-bc1205168b490c181cc54a43fb97c7e89b19835d.zip
x11-misc/gromit: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/gromit')
-rw-r--r--x11-misc/gromit/files/gromit-20041213-build.patch6
-rw-r--r--x11-misc/gromit/gromit-20041213-r2.ebuild (renamed from x11-misc/gromit/gromit-20041213-r1.ebuild)23
2 files changed, 12 insertions, 17 deletions
diff --git a/x11-misc/gromit/files/gromit-20041213-build.patch b/x11-misc/gromit/files/gromit-20041213-build.patch
index b539aa9e6dca..c32653410f5b 100644
--- a/x11-misc/gromit/files/gromit-20041213-build.patch
+++ b/x11-misc/gromit/files/gromit-20041213-build.patch
@@ -8,12 +8,12 @@ Fix underlinking for bug #369453.
proptest: proptest.c
- gcc -o proptest proptest.c `gtk-config --libs --cflags`
-+ $(CC) -o proptest proptest.c `gtk-config --libs --cflags`
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o proptest proptest.c `gtk-config --libs --cflags`
propertywatch: propertywatch.c
- gcc -o propertywatch propertywatch.c `gtk-config --libs --cflags`
-+ $(CC) -o propertywatch propertywatch.c `gtk-config --libs --cflags`
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o propertywatch propertywatch.c `gtk-config --libs --cflags`
gromit: gromit.c Makefile
- gcc -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall `pkg-config --libs --cflags gtk+-2.0`
-+ $(CC) -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall $(CFLAGS) $(LDFLAGS) `${PKG_CONFIG} --libs --cflags gtk+-2.0` -lX11 -lm
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall `$(PKG_CONFIG) --libs --cflags gtk+-2.0 x11` -lm
diff --git a/x11-misc/gromit/gromit-20041213-r1.ebuild b/x11-misc/gromit/gromit-20041213-r2.ebuild
index 5c81d81cc756..a5597d8987db 100644
--- a/x11-misc/gromit/gromit-20041213-r1.ebuild
+++ b/x11-misc/gromit/gromit-20041213-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -14,22 +14,17 @@ SLOT="0"
KEYWORDS="~amd64 ppc x86"
RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-PATCHES=(
- "${FILESDIR}"/${P}-build.patch
-)
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
-src_compile() {
- tc-export PKG_CONFIG
-
- emake CC="$(tc-getCC)"
+src_configure() {
+ tc-export CC PKG_CONFIG
}
src_install() {
- dobin ${PN}
- newdoc ${PN}rc ${PN}rc.example
+ dobin gromit
+ newdoc gromitrc gromitrc.example
einstalldocs
}